Printf.cpp coverage is still incorrect?

RESOLVED DUPLICATE of bug 1371970

Status

RESOLVED DUPLICATE of bug 1371970
a year ago
a year ago

People

(Reporter: ekyle, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
I think the Printf.cpp coverage is still incorrect.

Like, I think this line:

https://codecov.io/gh/marco-c/gecko-dev/src/master/mozglue/misc/Printf.cpp#L357

is exercised by the printf test; but that test isn't seen here:

https://codecov.io/gh/marco-c/gecko-dev/tree/master/mozglue
The gcda file for TestPrintf is missing, so I'm pretty sure we're not running it.
If I run it locally with "./mach cppunittest obj-x86_64-pc-linux-gnu/mozglue/tests/TestPrintf", the gcda file is correctly generated and the expected covered lines in Printf.cpp are actually covered.
No longer blocks: 1371970
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1371970
You need to log in before you can comment on or make changes to this bug.