Unresolved symbols when linking program to standalone SpiderMonkey

RESOLVED FIXED in Firefox -esr52

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: ptomato, Assigned: ptomato)

Tracking

(Blocks: 1 bug)

52 Branch
mozilla56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 fixed, firefox56 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

There are a few symbols that need to be marked as exported in the SpiderMonkey shared library, because they are used in the public headers.


Actual results:

Building a program that includes the SpiderMonkey public headers, fails with js::oom::GetThreadType() and js::ReportOutOfMemory() unresolvable.
(Assignee)

Comment 1

2 years ago
Here's a patch that works for me.
(Assignee)

Updated

2 years ago
Blocks: 1379541
(Assignee)

Updated

2 years ago
Blocks: 837921
Comment on attachment 8884717 [details] [diff] [review]
headers: Fix symbols visibility

Review of attachment 8884717 [details] [diff] [review]:
-----------------------------------------------------------------

Nick, this looks ok to me. WDYT?
Attachment #8884717 - Flags: review?(nfitzgerald)
Comment on attachment 8884717 [details] [diff] [review]
headers: Fix symbols visibility

Review of attachment 8884717 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!

Do you have commit access to push to try? If not, I can take this the rest of the way for you.
Attachment #8884717 - Flags: review?(nfitzgerald) → review+
(Assignee)

Comment 4

2 years ago
Cool, thanks for the reviews. I don't have commit access, so I'd appreciate if you could do the push.

Would it be possible to request backporting to ESR52, in preparation for an official tarball release, since this is pretty much required in order to use the tarball? Can I do that myself just by setting the "approval-mozilla-esr52?" flag?
Some symbols that need to be public are not marked as such.

(This is the same patch, but with an m-c formatted message.)
Attachment #8885381 - Flags: review+
Attachment #8884717 - Attachment is obsolete: true
Keywords: checkin-needed
Comment on attachment 8885381 [details] [diff] [review]
Unresolved symbols when linking program to standalone SpiderMonkey

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration: required for people embedding standalone spidermonkey 52
User impact if declined: people won't be able to embed standalone spidermonkey 52
Fix Landed on Version: in the process of landing now
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Attachment #8885381 - Flags: approval-mozilla-esr52?
(Assignee)

Comment 8

2 years ago
Thanks!
Assignee: nobody → philip.chimento

Comment 9

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/64c2fbd4b88c
Unresolved symbols when linking program to standalone SpiderMonkey. r=fitzgen
Keywords: checkin-needed

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/64c2fbd4b88c
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
status-firefox-esr52: --- → affected
Comment on attachment 8885381 [details] [diff] [review]
Unresolved symbols when linking program to standalone SpiderMonkey

This is needed for SpiderMonkey and low risk. Let's uplift it to ESR52.3.
Attachment #8885381 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
You need to log in before you can comment on or make changes to this bug.