push to releases script should not silently return success if nothing has been copied over

RESOLVED DUPLICATE of bug 1417568

Status

Release Engineering
Release Automation
P1
normal
RESOLVED DUPLICATE of bug 1417568
5 months ago
4 days ago

People

(Reporter: mtabara, Unassigned)

Tracking

({good-first-bug})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [releaseduty])

(Reporter)

Description

5 months ago
Push to releases for Fennec 55.0b1:

16:22:29     INFO - [mozharness: 2017-06-14 16:22:29.885249Z] Running push-to-releases step.
16:22:29     INFO - Running main action method: push_to_releases
16:22:29     INFO - Connecting to S3
16:22:29     INFO - Getting bucket net-mozaws-prod-delivery-archive
16:22:29     INFO - Checking destination pub/mobile/releases/55.0b1/ is empty
16:22:29     INFO - Getting key names from candidates
16:22:30     INFO - Copying pub/mobile/candidates/55.0b1-candidates/build2/android-api-15/az/fennec-55.0b1.az.android-arm.apk to pub/mobile/releases/55.0b1/android-api-15/az/fennec-55.0b1.az.android-arm.apk
.....
16:22:40     INFO - [mozharness: 2017-06-14 16:22:40.770327Z] Finished push-to-releases step (success)

Push to releases for Fennec 55.0b7:

15:55:38     INFO - [mozharness: 2017-07-07 15:55:38.557428Z] Finished create-virtualenv step (success)
15:55:38     INFO - [mozharness: 2017-07-07 15:55:38.557595Z] Running activate-virtualenv step.
15:55:38     INFO - Running main action method: activate_virtualenv
15:55:38     INFO - [mozharness: 2017-07-07 15:55:38.558479Z] Finished activate-virtualenv step (success)
15:55:38     INFO - [mozharness: 2017-07-07 15:55:38.558617Z] Running push-to-releases step.
15:55:38     INFO - Running main action method: push_to_releases
15:55:38     INFO - Connecting to S3
15:55:38     INFO - Getting bucket net-mozaws-prod-delivery-archive
15:55:38     INFO - Checking destination pub/mobile/releases/57.0b7/ is empty
15:55:38     INFO - Getting key names from candidates
15:55:38     INFO - [mozharness: 2017-07-07 15:55:38.649553Z] Finished push-to-releases step (success)

Both tasks are green and return success. This is wrong.
Push to releases should return Fail so that we have a warning that nothing has been copied over from ~/candidates -> ~/releases.
We should add that check right after "Getting key names from candidates".
(Reporter)

Comment 1

5 months ago
Adding this to the releaseduty pool of release automation improvements.
Keywords: good-first-bug
Priority: -- → P2
Whiteboard: [releaseduty]
(Reporter)

Updated

5 months ago
Assignee: mtabara → nobody
(Reporter)

Updated

4 months ago
Priority: P2 → P1
(Reporter)

Comment 2

4 days ago
Fixed in the new world in beetmover! \o/
Status: NEW → RESOLVED
Last Resolved: 4 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1417568
You need to log in before you can comment on or make changes to this bug.