mozilla sometimes prevents hibernation/hibernate

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
minor
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Daniel Steinberger, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020415
BuildID:    2002041503

windows XP (and win2k, too, but there i didn't test it) has the ability to
hibernate (suspend to disk) the system via ACPI. this means all your running
programs and applications get freezed in the current state (including all
windows and even unsaved data), so you can turn your computer off and resume
your work later.

sometimes mozilla prevents the system from doing this. if i choose to shut down
the PC via hibernation, it sometimes shows the correct shutdown-screen but than
returns to the desktop without an errormessage or having hibernated.

if i quit mozilla afterwards and try again, it hibernates without a problem.
strangely it sometimes does work to hibernate, even if mozilla is running.

Reproducible: Sometimes
Steps to Reproduce:
1. have mozilla running (with quicklaunch maybe?)
2. select "turn off computer"
3. select "hibernate"

note that it does not matter, if you have open windows or not (of cause you've
got to have 'quicklaunch' enabled then)

Actual Results:  sometimes hibernation fails
Expected Results:  hibernation works every time

Comment 1

16 years ago
Possible duplicate of bug 124369.
(Reporter)

Comment 2

16 years ago
i don't think this is a dup of bug 124369, since it deals with suspend to ram
(standby). and according to the description the laptop always is able to enter
the suspend mode. my problem is, that hibernation does not even take place.
after returning from hibernation (when it succeeded) mozilla works without problems.
-> XP APPS
Assignee: Matti → sgehani
Component: Browser-General → XP Apps
QA Contact: imajes-qa → paw

Comment 4

16 years ago
-> Windows guru, Bill
Assignee: sgehani → law

Comment 5

15 years ago
It's happening for me too. I'm using Win2k SP3 with mozilla 1.2.1.
It was working perfectly with Mozilla 1.1 and now it never works if any windows
are open from mozilla. It only works when guicklaunch icon is just restarted (eg
close all mozilla windows and wait till mozilla has restarted).

The symthomes are exactly as descripted by Daniel Steinberger.
Windows displays "Preparing for hibernation" (or in German "Ruhezustand")
Then the display,keyboard,harddisks and all usb divices are turned off.
Then it resumes as if it was in suspend mode and the user has pressed a key. But
it didn't ask for a login as it would when resuming from hibernation.

Comment 6

15 years ago
Ok,

I've found something:
I've running a selfwritten program that uses powerbroadcasts (WM_POWERBROADCAST)
to stop audioplayback on suspend. And this program receivs a
PBT_APMRESUMEAUTOMATIC event. This means that windows has stoped hibernation
because an (timerdriver?) event has occured that should wakeup the system.

Till now I don't know what could create such an event.

More info @
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/power/base/pbt_apmresumeautomatic.asp

Comment 7

15 years ago
Ok,

I've found something that can wake up the system. It's a timer object.

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/power/base/system_wake_up_events.asp

I couldn't find references to this in the mozilla code. Maybe it's uses by some
plugins or COM objects ?

Comment 8

14 years ago
i cannot confirm this neither with xp nor 2k. but im not using quick launch, so
i guess it has probably something to do with the quick launch code.

Comment 9

14 years ago
I'm now using Mozilla 1.4 and the problem has not reappered. I think it is fixed.
(Reporter)

Comment 10

14 years ago
well... okay. since i don't experience this anymore, too... (well, i've actually
switched to firebird without quicklaunch, but can't remember to have had
problems before that anymore, too... it's already been a while) i'll make this
one WORKSFORME, since it seems no extra work/code has been done for this.

if anyone is still seeing this, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite

Updated

3 years ago
Blocks: 1125998

Updated

3 years ago
No longer blocks: 1125998
You need to log in before you can comment on or make changes to this bug.