Autophone - autophone-1 pixel-03 performance degradation

RESOLVED FIXED

Status

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: bc, Assigned: van)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Beginning on 2017-07-06 pixel-03's composite binned measurements jumped from 750 to 22,000.

http://phonedash.mozilla.org/#/2017-07-06/2017-07-07/binning=repo-phonetype-phoneid-test_name-cached_label-metric&rejected=norejected&errorbars=noerrorbars&errorbartype=standarderror&valuetype=median&geckoview-e10s-nytimes=on&geckoview-nytimes=on&remote-blank=on&remote-nytimes=on&remote-twitter=on&throbberstart=on&throbberstop=on&throbbertime=on&first=on&second=on&autoland=on&mozilla-beta=on&mozilla-central=on&mozilla-inbound=on&nexus-4=on&nexus-4-8=on&nexus-4-9=on&nexus-5=on&nexus-5-1=on&nexus-5-3=on&nexus-5-5=on&nexus-5-6=on&nexus-6p=on&nexus-6p-10=on&nexus-6p-11=on&nexus-6p-12=on&nexus-9=on&nexus-9-2=on&pixel=on&pixel-03=on&pixel-04=on&pixel-05=on&pixel-06=on&pixel-10=on

This occurs across the repositories and is unrelated to any product change but is almost certainly a device failure. pixel-03 has been having issues with disconnections recently.

Unless there is something evident from just looking at the phone that is has failed, the only other option is to reflash the device back to factory, re-root it and re-configure it. I think I can handle everything remotely except the manual reconfiguration of the device which will require manual intervention there. The other option is to ship the phone to me where I can attempt to recover it.

Van, Stephend: Do either of you have time to reconfigure the device if I can remotely reflash and reroot it? Or should we just ship it here?
Flags: needinfo?(vle)
Flags: needinfo?(stephen.donner)
(Assignee)

Comment 1

a year ago
i believe stephend is out of the office on PTO for some time. please flash it and ill help you reconfigure the device.
Flags: needinfo?(stephen.donner)
(Reporter)

Comment 2

a year ago
Created attachment 8884896 [details]
pixel-03.txt

I've flashed the device. We need to first enable usb debugging, then I will need to root the device, then we can finish setting it up.

Van: The attached document lists the changes we need to make. Ping me when you go into the lab and I'll work through the list with you.
(Reporter)

Comment 3

a year ago
With Van's help we were able to reflash and reroot pixel-03. The measurements have fallen back into the normal range so the issue with the performance degradation is gone though we don't know what the cause was. I have marked the offending measurements in phonedash.mozilla.org as "rejected". This means they will not display by default but are still available in the database and can be viewed by selecting "Include rejected results" in the graph ui.

Thanks Van!
Assignee: nobody → vle
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(vle)
Resolution: --- → FIXED
(Reporter)

Comment 4

a year ago
igoldan: This should be resolved now.
You need to log in before you can comment on or make changes to this bug.