Closed Bug 1379715 Opened 5 years ago Closed 5 years ago

Grid Inspector Area Names are giant when they overflow

Categories

(DevTools :: Inspector, defect)

defect
Not set
normal

Tracking

(firefox56 verified, firefox57 verified)

VERIFIED FIXED
Firefox 56
Tracking Status
firefox56 --- verified
firefox57 --- verified

People

(Reporter: jensimmons, Assigned: micah)

References

(Blocks 1 open bug)

Details

(Keywords: DevAdvocacy)

Attachments

(1 file)

To reproduce this bug:
1. Open this demo in Nightly: https://s.codepen.io/jensimmons/debug/gRQoYL
2. Show the Grid and the Grid Area Names.
3. See the size of the area names in the first example. Then look at the seocond example and see how the are names are much larger.

Also — looks like this: https://monosnap.com/file/zAgZz6pDMgyGSpD1S7PsKalYZNrc7l.png

See the code for this example at:https://codepen.io/jensimmons/pen/gRQoYL?editors=1100#0

My guess (and it's just a guess) is that the font size is jumping up because there's not enough space / vertical overflow. Somehow. 

This bug was found by Eric Meyer. Thanks Eric.
Blocks: dt-grid
Component: Developer Tools → Developer Tools: Inspector
Assignee: nobody → tigleym
Status: NEW → ASSIGNED
Comment on attachment 8885564 [details]
Bug 1379715 - Grid Inspector Area Names are giant when they overflow.

https://reviewboard.mozilla.org/r/156418/#review162896
Attachment #8885564 - Flags: review?(gl) → review+
Flags: qe-verify+
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3da4ad542ed3
Grid Inspector Area Names are giant when they overflow. r=gl
https://hg.mozilla.org/mozilla-central/rev/3da4ad542ed3
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
I tried to reproduce this bug using old Nightly from 2017-07-10 but I could not reproduce it. I also tried on latest Nightly (2017-08-16), Beta 56.0b3 and Firefox RC 55.0.2 (after enabling layout from prefs) using macOS 10.12 and I couldn't manage to reproduce it. 

I used the link from comment 0 https://codepen.io/jensimmons/pen/gRQoYL?editors=1100#0, but the area names always had the same size. Can you please give me some additional information about how could I reproduce it or if you have time verify it yourself on 56beta3 build?
Flags: needinfo?(jensimmons)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #5)
> I tried to reproduce this bug using old Nightly from 2017-07-10 but I could
> not reproduce it. I also tried on latest Nightly (2017-08-16), Beta 56.0b3
> and Firefox RC 55.0.2 (after enabling layout from prefs) using macOS 10.12
> and I couldn't manage to reproduce it. 
> 
> I used the link from comment 0
> https://codepen.io/jensimmons/pen/gRQoYL?editors=1100#0, but the area names
> always had the same size. Can you please give me some additional information
> about how could I reproduce it or if you have time verify it yourself on
> 56beta3 build?

This was a device pixel ratio issue. If I recalled correctly, this only happened for retina displays. One way to reproduce this would be to use the Responsive Design Mode and change the Device Pixel Ratio to 2x.
Flags: needinfo?(jensimmons)
(In reply to Gabriel [:gl] (ΦωΦ) from comment #6)
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #5)
> > I tried to reproduce this bug using old Nightly from 2017-07-10 but I could
> > not reproduce it. I also tried on latest Nightly (2017-08-16), Beta 56.0b3
> > and Firefox RC 55.0.2 (after enabling layout from prefs) using macOS 10.12
> > and I couldn't manage to reproduce it. 
> > 
> > I used the link from comment 0
> > https://codepen.io/jensimmons/pen/gRQoYL?editors=1100#0, but the area names
> > always had the same size. Can you please give me some additional information
> > about how could I reproduce it or if you have time verify it yourself on
> > 56beta3 build?
> 
> This was a device pixel ratio issue. If I recalled correctly, this only
> happened for retina displays. One way to reproduce this would be to use the
> Responsive Design Mode and change the Device Pixel Ratio to 2x.

Thanks Gabriel!
After I changed the Pixel Ratio to 2x I managed to reproduce the bug on old Nightly from 2017-07-10 using macOS 10.12. 

I verified on latest Nightly and beta 56.0b3 using macOS 10.12, Windows 10 x64 and Ubuntu 16.04 x64, I couldn't reproduce the problem anymore. I would say that the issue is fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Yes, this looks fixed to me, too. Thanks!
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.