Closed Bug 1379782 Opened 2 years ago Closed 2 years ago

Reload button is inaccessible for about 1 second at end of Stop/Reload button animation

Categories

(Firefox :: Theme, defect, major)

56 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED INVALID

People

(Reporter: Virtual, Unassigned)

References

Details

(Keywords: nightly-community)

STR:
1. Open some lightweighted website page
2. Reload it
and see that after page was loaded (tip - look on favicon) Reload button is inaccessible and you can't press it for about 1 second

I suggest changing second "X" part of the animation to ending "refresh" animation, so it will start sooner and users could still press reload button at end of whole animation, without any delay and waiting for its accessibility.
Flags: needinfo?(jaws)
Has Regression Range: --- → yes
Has STR: --- → yes
This is by design, see bug 1376893 which just made the disabled state not obvious.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jaws)
Resolution: --- → WONTFIX
Whiteboard: [photon-animation] [triage]
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #0)
> I suggest changing second "X" part of the animation to ending "refresh"
> animation, so it will start sooner and users could still press reload button
> at end of whole animation, without any delay and waiting for its
> accessibility.

Unfortunately we can't "start sooner" because we don't know when the load will stop.
I meant instead of this (like it's now):
- press "Reload" button
- "X" (Stop) animation runs one time
- and change to static "X"(Stop) image
- when page loaded, next animation runs, which is "X/Reload" animation

go with something like:
- press "Reload" button
- "X" (Stop) animation runs one time
- and change to static "X"(Stop) image
- when page loaded, next animation runs, which is just only "Reload" animation,
without "X" animation, so it will be much faster, especially when there is nothing to "Stop", so animating "X" (stop) when page loaded is very bad idea and kinda illogical

but I wonder why even Firefox developers want users attention to stopping or reloading pages, I think that usage of this button is minimal (maybe telemetry will help), especially when users see it on: Connecting status floating bar in bottom left and in Connecting favicon animation near tab name

overall this animation is kinda useless and too distracting, but that issue is being tracked in bug #1379480

+ ni so you will see my reply :)
Flags: needinfo?(jaws)
Thanks for the needinfo.

Animations and movements in software should model animations and movement seen in the "real world". This means that we don't see moving items immediately stop without some easing, as well we don't see items change forms without some level of morphing. The animation implemented shows the changing from stop <-> reload which is more natural than the immediate switch.

Bug 1381957 is on file to speed up the animation, so it may not be as obvious or distracting after those changes.

As I said earlier, even when we didn't have the animation the button was still inaccessible for the first 650 milliseconds of showing the Reload button so as not to accidentally hit Reload when the user meant to hit Stop.
Flags: needinfo?(jaws)
OK. Thank you very much for detailed information.


(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #4)
> As I said earlier, even when we didn't have the animation the button was
> still inaccessible for the first 650 milliseconds of showing the Reload
> button so as not to accidentally hit Reload when the user meant to hit Stop.

Oddly, pressing button after changing from stop to reload, work nearly immediately in no animation mode,
or maybe I'm pressing it not fast enough. ;)
Status: RESOLVED → VERIFIED
Has Regression Range: yes → ---
Has STR: yes → ---
Keywords: regression
You need to log in before you can comment on or make changes to this bug.