firefox -silent no longer exits

RESOLVED FIXED in Firefox 56

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: bc, Assigned: aswan)

Tracking

({regression})

56 Branch
mozilla56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

(crash signature)

Attachments

(2 attachments)

Prior to bug 1358907 landing, starting firefox with -silent would essentially initialize the profile then exit. Afterwards, firefox emits

WARNING: At least one completion condition is taking too long to complete. Conditions: [{"name":"EnvironmentAddonBuilder","state":"(none)","filename":"resource://gre/modules/TelemetryEnvironment.jsm","lineNumber":479,"stack":["resource://gre/modules/TelemetryEnvironment.jsm:init:479","resource://gre/modules/TelemetryEnvironment.jsm:EnvironmentCache:841","resource://gre/modules/TelemetryEnvironment.jsm:getGlobal:59","resource://gre/modules/TelemetryEnvironment.jsm:get currentEnvironment:66","jar:file:///tmp/tmpZ4lqAF/firefox/omni.ja!/components/TelemetryStartup.js:annotateEnvironment:42","jar:file:///tmp/tmpZ4lqAF/firefox/omni.ja!/components/TelemetryStartup.js:TelemetryStartup.prototype.observe:32"]}] Barrier: AddonManager: Waiting for providers to shut down.
WARNING: At least one completion condition is taking too long to complete. Conditions: [{"name":"AddonManager: shutting down.","state":[{"name":"AddonManager: Waiting for providers to shut down.","state":[{"name":"EnvironmentAddonBuilder","state":"(none)","filename":"resource://gre/modules/TelemetryEnvironment.jsm","lineNumber":479,"stack":["resource://gre/modules/TelemetryEnvironment.jsm:init:479","resource://gre/modules/TelemetryEnvironment.jsm:EnvironmentCache:841","resource://gre/modules/TelemetryEnvironment.jsm:getGlobal:59","resource://gre/modules/TelemetryEnvironment.jsm:get currentEnvironment:66","jar:file:///tmp/tmpZ4lqAF/firefox/omni.ja!/components/TelemetryStartup.js:annotateEnvironment:42","jar:file:///tmp/tmpZ4lqAF/firefox/omni.ja!/components/TelemetryStartup.js:TelemetryStartup.prototype.observe:32"]}]},{"name":"AddonRepository: async shutdown","state":"pending"}],"filename":"resource://gre/modules/AddonManager.jsm","lineNumber":898,"stack":["resource://gre/modules/AddonManager.jsm:startup:898","resource://gre/modules/AddonManager.jsm:startup:3090","jar:file:///tmp/tmpZ4lqAF/firefox/omni.ja!/components/addonManager.js:observe:65"]}] Barrier: profile-before-change
Keywords: regression
Note you will get a shutdown crash if you wait long enough. Example bp-ceb94a27-1c3a-4b5e-802a-9ccfd1170710
[@ AsyncShutdownTimeout | AddonManager: Waiting for providers to shut down. | EnvironmentAddonBuilder ]

Possibly related Thunderbird crash: bug 1379518
Crash Signature: [@ AsyncShutdownTimeout | AddonManager: Waiting for providers to shut down. | EnvironmentAddonBuilder ]
Do we care about getting full shutdown pings from these firefox runs?  (I'm guessing the answer is yes...)
This seems like an edge-case for Telemetry reporting.
If these makes things easier, i don't think we need the full addon details for these pings.
AFAICT, per bug 1358907 we are now indirectly blocking on the "xpi-database-loaded" notification on shutdown:
https://dxr.mozilla.org/mozilla-central/rev/b07db5d650b7056c78ba0dbc409d060ec4e922cd/toolkit/components/telemetry/TelemetryEnvironment.jsm#494

We can't block on that, unless it is guaranteed to always be fired before that shutdown stage.
Options i can think of:
(1) make sure in the shutdown blocker that the database will be loaded (how?)
(2) don't block on "xpi-database-loaded"
  - we need to make sure that this is guaranteed to be fired within, say, 5min of startup though
Andrew, what do you think about (1) vs. (2)?
Flags: needinfo?(aswan)
I would love to do #2 but that would mean that if we never need to load the XPI database that shutdown pings would not contain detailed addon information.  Over in bug 1358907 the telemetry team was pretty strongly opposed to that.  If we can revisit that, and not load the database if it unneeded, that would be great.  If not, that leaves us with #1 which I think is actually pretty easy to do, we just fire an event when telemetry shuts down that loads the XPI database if it is not already loaded.  If it is, the event is just ignored and no harm is done.
If you prefer the second option, feel free to assign the bug to me.
Flags: needinfo?(aswan)
Ok, #2 is currently not an option for us, we need to have the full addon data (except for some edge-cases like discussed in bug 1358907).

What needs to be done for #1?
Flags: needinfo?(aswan)
(In reply to Georg Fritzsche [:gfritzsche] from comment #8)
> What needs to be done for #1?

What I described in comment 7, I'll write a patch.
Assignee: nobody → aswan
Flags: needinfo?(aswan)
Attachment #8885520 - Flags: review?(dtownsend)
Priority: -- → P1
Comment on attachment 8885520 [details]
Bug 1379831 Make sure we always load the XPI database

https://reviewboard.mozilla.org/r/156388/#review161642

Ick
Attachment #8885520 - Flags: review?(dtownsend) → review+
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/450742adef3e
Make sure we always load the XPI database r=mossop
https://hg.mozilla.org/mozilla-central/rev/450742adef3e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Duplicate of this bug: 1379518
Posted file log
Is this really fixed? I did a depends build this morning and still get a shutdown crash with

firefox -CreateProfile testprofile /tmp/testprofile
firefox -P testprofile -silent

I'll do a clobber build next.
Thunderbird topcrash is gone in July 14 build.

Less commmon crash signatures continue:

AsyncShutdownTimeout | profile-change-teardown | Extension Shutdown: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Web Extensions I/O backend)  bp-ba2ae385-2e22-4f4d-9354-573fe0170714

AsyncShutdownTimeout | web-workers-shutdown | OS.File: flush pending requests, warn about unclosed files, shut down service.  bp-1d3455c4-913b-4a24-94f0-e1d1e0170714

AsyncShutdownTimeout | profile-change-teardown | Extension Shutdown: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} (Web Extensions I/O backend)  bp-eb9c21e5-9f6a-4b29-a7f1-ec6570170714
aswan: I clobbered and still reproduced the hang/crash with a fresh nightly build. Fwiw, I also tested a fresh clobber build of beta and it does not hang/crash.
Flags: needinfo?(aswan)
bc: is this in a clean profile?  Do you have any of the "completion condition is taking too long to complete" logs from a shutdown crash?
Flags: needinfo?(aswan)
This is a clean profile created via -CreateProfile. The commands I used and the log of the output is in attachment 8886655 [details].
The command line from the attachment is:
/mozilla/builds/nightly/mozilla/firefox-debug/dist/bin/firefox -CreateProfile testprofile /tmp/testprofile

which doesn't include the -silent argument.  And I'm not sure what you're trying to do, for me that command line creates a profile called testprofile then tries to open the (nonexistent for me) directory /tmp/testprofile.  Nevertheless, if I quit the browser after this it exits cleanly...

What hg revision did you build from?  What platform are you on?
Sorry, I should have been more clear.

The revision my most recent build used was https://hg.mozilla.org/mozilla-central/rev/2908b6171cb8df85fc1f0985e2bf94ce3b04a522

This is on Fedora 25 x86_64.

There are two commands:

firefox -CreateProfile testprofile
firefox -P testprofile -silent

The /tmp/testprofile directory is erroneous which I realized later but didn't mention.
Looks like this improved the perf a bit:

== Change summary for alert #7886 (as of July 12 2017 21:34 UTC) ==

Improvements:

  4%  remote-nytimes summary android-4-2-armv7-api15 opt      3,946.23 -> 3,777.35

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=7886
I'm still not understanding the STR.  With which command (the first one with -CreateProfile or the second one with -silent) are you seeing the shutdown crash?  Can you get a full crash report?
Flags: needinfo?(bob)
The hang occurs after the firefox -P testprofile -silent

$ ./firefox -CreateProfile testprofile
Success: created profile 'testprofile' at '/home/bclary/.mozilla/firefox/ap8nb462.testprofile/prefs.js'

$ ./firefox -P testprofile -silent
Extension error: Data is not ready. resource://gre/modules/JSONFile.jsm:159 :: get data@resource://gre/modules/JSONFile.jsm:159:13
_get@resource://gre/modules/ExtensionPermissions.jsm:65:9
async*_getCached/<@resource://gre/modules/ExtensionPermissions.jsm:76:47
get@resource://gre/modules/ExtensionParent.jsm:1471:22
async*_getCached@resource://gre/modules/ExtensionPermissions.jsm:75:12
async*get@resource://gre/modules/ExtensionPermissions.jsm:80:12
_startup@resource://gre/modules/Extension.jsm:1101:9
async*startup@resource://gre/modules/Extension.jsm:1068:27
startup/this.startupPromise<@resource://gre/modules/LegacyExtensionsUtils.jsm:188:7
startup@resource://gre/modules/LegacyExtensionsUtils.jsm:140:27
start@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/bclary/bin/nightly/firefox/browser/features/screenshots@mozilla.org.xpi!/bootstrap.js:113:3
handleStartup@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/bclary/bin/nightly/firefox/browser/features/screenshots@mozilla.org.xpi!/bootstrap.js:106:5
promise callback*startup@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/bclary/bin/nightly/firefox/browser/features/screenshots@mozilla.org.xpi!/bootstrap.js:75:3
callBootstrapMethod@resource://gre/modules/addons/XPIProvider.jsm:4385:11
startup@resource://gre/modules/addons/XPIProvider.jsm:2223:13
callProvider@resource://gre/modules/AddonManager.jsm:269:12
_startProvider@resource://gre/modules/AddonManager.jsm:739:5
startup@resource://gre/modules/AddonManager.jsm:906:9
startup@resource://gre/modules/AddonManager.jsm:3090:5
observe@jar:file:///home/bclary/bin/nightly/firefox/omni.ja!/components/addonManager.js:65:9

console.error: 
  Message: Error: Data is not ready.
  Stack:
    get data@resource://gre/modules/JSONFile.jsm:159:13
_get@resource://gre/modules/ExtensionPermissions.jsm:65:9
async*_getCached/<@resource://gre/modules/ExtensionPermissions.jsm:76:47
get@resource://gre/modules/ExtensionParent.jsm:1471:22
async*_getCached@resource://gre/modules/ExtensionPermissions.jsm:75:12
async*get@resource://gre/modules/ExtensionPermissions.jsm:80:12
_startup@resource://gre/modules/Extension.jsm:1101:9
async*startup@resource://gre/modules/Extension.jsm:1068:27
startup/this.startupPromise<@resource://gre/modules/LegacyExtensionsUtils.jsm:188:7
startup@resource://gre/modules/LegacyExtensionsUtils.jsm:140:27
start@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/bclary/bin/nightly/firefox/browser/features/screenshots@mozilla.org.xpi!/bootstrap.js:113:3
handleStartup@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/bclary/bin/nightly/firefox/browser/features/screenshots@mozilla.org.xpi!/bootstrap.js:106:5
promise callback*startup@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/bclary/bin/nightly/firefox/browser/features/screenshots@mozilla.org.xpi!/bootstrap.js:75:3
callBootstrapMethod@resource://gre/modules/addons/XPIProvider.jsm:4385:11
startup@resource://gre/modules/addons/XPIProvider.jsm:2223:13
callProvider@resource://gre/modules/AddonManager.jsm:269:12
_startProvider@resource://gre/modules/AddonManager.jsm:739:5
startup@resource://gre/modules/AddonManager.jsm:906:9
startup@resource://gre/modules/AddonManager.jsm:3090:5
observe@jar:file:///home/bclary/bin/nightly/firefox/omni.ja!/components/addonManager.js:65:9

WARNING: At least one completion condition is taking too long to complete. Conditions: [{"name":"EnvironmentAddonBuilder","state":"(none)","filename":"resource://gre/modules/TelemetryEnvironment.jsm","lineNumber":479,"stack":["resource://gre/modules/TelemetryEnvironment.jsm:init:479","resource://gre/modules/TelemetryEnvironment.jsm:EnvironmentCache:841","resource://gre/modules/TelemetryEnvironment.jsm:getGlobal:59","resource://gre/modules/TelemetryEnvironment.jsm:get currentEnvironment:66","jar:file:///home/bclary/bin/nightly/firefox/omni.ja!/components/TelemetryStartup.js:annotateEnvironment:42","jar:file:///home/bclary/bin/nightly/firefox/omni.ja!/components/TelemetryStartup.js:TelemetryStartup.prototype.observe:32"]}] Barrier: AddonManager: Waiting for providers to shut down.
WARNING: At least one completion condition is taking too long to complete. Conditions: [{"name":"AddonManager: shutting down.","state":[{"name":"AddonManager: Waiting for providers to shut down.","state":[{"name":"EnvironmentAddonBuilder","state":"(none)","filename":"resource://gre/modules/TelemetryEnvironment.jsm","lineNumber":479,"stack":["resource://gre/modules/TelemetryEnvironment.jsm:init:479","resource://gre/modules/TelemetryEnvironment.jsm:EnvironmentCache:841","resource://gre/modules/TelemetryEnvironment.jsm:getGlobal:59","resource://gre/modules/TelemetryEnvironment.jsm:get currentEnvironment:66","jar:file:///home/bclary/bin/nightly/firefox/omni.ja!/components/TelemetryStartup.js:annotateEnvironment:42","jar:file:///home/bclary/bin/nightly/firefox/omni.ja!/components/TelemetryStartup.js:TelemetryStartup.prototype.observe:32"]}]},{"name":"AddonRepository: async shutdown","state":"pending"}],"filename":"resource://gre/modules/AddonManager.jsm","lineNumber":898,"stack":["resource://gre/modules/AddonManager.jsm:startup:898","resource://gre/modules/AddonManager.jsm:startup:3090","jar:file:///home/bclary/bin/nightly/firefox/omni.ja!/components/addonManager.js:observe:65"]}] Barrier: profile-before-change
*** UTM:SVC TimerManager:registerTimer called after profile-before-change notification. Ignoring timer registration for id: telemetry_modules_ping
FATAL ERROR: AsyncShutdown timeout in AddonManager: Waiting for providers to shut down. Conditions: [{"name":"EnvironmentAddonBuilder","state":"(none)","filename":"resource://gre/modules/TelemetryEnvironment.jsm","lineNumber":479,"stack":["resource://gre/modules/TelemetryEnvironment.jsm:init:479","resource://gre/modules/TelemetryEnvironment.jsm:EnvironmentCache:841","resource://gre/modules/TelemetryEnvironment.jsm:getGlobal:59","resource://gre/modules/TelemetryEnvironment.jsm:get currentEnvironment:66","jar:file:///home/bclary/bin/nightly/firefox/omni.ja!/components/TelemetryStartup.js:annotateEnvironment:42","jar:file:///home/bclary/bin/nightly/firefox/omni.ja!/components/TelemetryStartup.js:TelemetryStartup.prototype.observe:32"]}] At least one completion condition failed to complete within a reasonable amount of time. Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources.
[10413] ###!!! ABORT: file resource://gre/modules/TelemetryEnvironment.jsm, line 479
[10413] ###!!! ABORT: file resource://gre/modules/TelemetryEnvironment.jsm, line 479
ExceptionHandler::GenerateDump cloned child 10562
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

Crash Report [@ AsyncShutdownTimeout | AddonManager: Waiting for providers to shut down. | EnvironmentAddonBuilder ]

bp-d10f770f-bc8c-45ac-b09f-2881e0170717
bp-c664fbc3-f11a-45aa-941e-7d68c0170717

Application Basics
------------------

Name: Firefox
Version: 56.0a1
Build ID: 20170717100212
Update Channel: nightly
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
OS: Linux 4.11.9-300.fc26.x86_64
Multiprocess Windows: 1/1 (Enabled by default)
Stylo: false (disabled by default)
Google Key: Found
Mozilla Location Service Key: Found
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-c664fbc3-f11a-45aa-941e-7d68c0170717
Submitted: 2 minutes ago

Report ID: bp-d10f770f-bc8c-45ac-b09f-2881e0170717
Submitted: 3 minutes ago

All Crash Reports

Nightly Features
----------------

Name: Activity Stream
Version: 0.0.0
ID: activity-stream@mozilla.org

Name: Application Update Service Helper
Version: 2.0
ID: aushelper@mozilla.org

Name: Click-to-Play staged rollout
Version: 1.2
ID: clicktoplay-rollout@mozilla.org

Name: Firefox Screenshots
Version: 10.5.0
ID: screenshots@mozilla.org

Name: FlyWeb
Version: 1.0.0
ID: flyweb@mozilla.org

Name: Follow-on Search Telemetry
Version: 0.9.1
ID: followonsearch@mozilla.com

Name: Form Autofill
Version: 1.0
ID: formautofill@mozilla.org

Name: Multi-process staged rollout
Version: 1.80
ID: e10srollout@mozilla.org

Name: Photon onboarding
Version: 0.1
ID: onboarding@mozilla.org

Name: Pocket
Version: 1.0.5
ID: firefox@getpocket.com

Name: Presentation
Version: 1.0.0
ID: presentation@mozilla.org

Name: Shield Recipe Client
Version: 55
ID: shield-recipe-client@mozilla.org

Name: Web Compat
Version: 1.1
ID: webcompat@mozilla.org

Name: WebCompat Reporter
Version: 1.0.0
ID: webcompat-reporter@mozilla.org

Extensions
----------

Graphics
--------

Features
Compositing: Basic
Asynchronous Pan/Zoom: wheel input enabled; scrollbar drag enabled
WebGL 1 Driver WSI Info: GLX 1.4 GLX_VENDOR(client): Mesa Project and SGI GLX_VENDOR(server): SGI Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_fbconfig_packed_float GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_EXT_create_context_es_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event GLX_EXT_buffer_age
WebGL 1 Driver Renderer: nouveau -- Gallium 0.4 on NVC1
WebGL 1 Driver Version: 3.0 Mesa 17.1.4
WebGL 1 Driver Extensions: GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_framebuffer_sRGB GL_ARB_multitexture GL_EXT_framebuffer_sRGB GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_S3_s3tc GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_compression_s3tc GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_occlusion_query GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_ATI_fragment_shader GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_NV_depth_clamp GL_NV_fog_distance GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_depth_bounds_test GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_NV_primitive_restart GL_ARB_depth_clamp GL_ARB_fragment_program_shadow GL_ARB_half_float_pixel GL_ARB_occlusion_query2 GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_color_buffer_float GL_ARB_pixel_buffer_object GL_ARB_texture_compression_rgtc GL_ARB_texture_float GL_ARB_texture_rectangle GL_ATI_texture_compression_3dc GL_EXT_packed_float GL_EXT_pixel_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_rgtc GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_shared_exponent GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_packed_depth_stencil GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_ATI_texture_mirror_once GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_gpu_program_parameters GL_EXT_texture_array GL_EXT_texture_compression_latc GL_EXT_texture_integer GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_OES_EGL_image GL_AMD_performance_monitor GL_ARB_copy_buffer GL_ARB_depth_buffer_float GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_map_buffer_range GL_ARB_texture_rg GL_ARB_texture_swizzle GL_ARB_vertex_array_bgra GL_EXT_texture_swizzle GL_EXT_vertex_array_bgra GL_NV_conditional_render GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_ARB_ES2_compatibility GL_ARB_blend_func_extended GL_ARB_debug_output GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_conventions GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_shader_texture_lod GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_multisample GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_uniform_buffer_object GL_ARB_vertex_type_2_10_10_10_rev GL_EXT_provoking_vertex GL_EXT_texture_snorm GL_MESA_texture_signed_rgba GL_NV_texture_barrier GL_ARB_get_program_binary GL_ARB_robustness GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_precision GL_ARB_texture_compression_bptc GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_NV_vdpau_interop GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ARB_base_instance GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_internalformat_query GL_ARB_map_buffer_alignment GL_ARB_shader_atomic_counters GL_ARB_shader_image_load_store GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_texture_storage GL_ARB_transform_feedback_instanced GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_transform_feedback GL_AMD_shader_trinary_minmax GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_clear_buffer_object GL_ARB_compute_shader GL_ARB_copy_image GL_ARB_explicit_uniform_location GL_ARB_framebuffer_no_attachments GL_ARB_invalidate_subdata GL_ARB_program_interface_query GL_ARB_robust_buffer_access_behavior GL_ARB_shader_image_size GL_ARB_shader_storage_buffer_object GL_ARB_stencil_texturing GL_ARB_texture_query_levels GL_ARB_texture_storage_multisample GL_ARB_texture_view GL_ARB_vertex_attrib_binding GL_KHR_debug GL_KHR_robustness GL_ARB_buffer_storage GL_ARB_clear_texture GL_ARB_compute_variable_group_size GL_ARB_internalformat_query2 GL_ARB_multi_bind GL_ARB_query_buffer_object GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_stencil8 GL_ARB_vertex_type_10f_11f_11f_rev GL_EXT_shader_integer_mix GL_ARB_clip_control GL_ARB_conditional_render_inverted GL_ARB_cull_distance GL_ARB_derivative_control GL_ARB_get_texture_sub_image GL_ARB_pipeline_statistics_query GL_ARB_shader_texture_image_samples GL_ARB_texture_barrier GL_EXT_polygon_offset_clamp GL_KHR_context_flush_control GL_KHR_robust_buffer_access_behavior GL_ARB_shader_atomic_counter_ops GL_ARB_shader_clock GL_EXT_window_rectangles GL_MESA_shader_integer_functions
WebGL 1 Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_etc WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
WebGL 2 Driver WSI Info: GLX 1.4 GLX_VENDOR(client): Mesa Project and SGI GLX_VENDOR(server): SGI Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_fbconfig_packed_float GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_EXT_create_context_es_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event GLX_EXT_buffer_age
WebGL 2 Driver Renderer: nouveau -- Gallium 0.4 on NVC1
WebGL 2 Driver Version: 4.3 (Core Profile) Mesa 17.1.4
WebGL 2 Driver Extensions: GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_AMD_performance_monitor GL_AMD_shader_trinary_minmax GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ARB_ES2_compatibility GL_ARB_ES3_1_compatibility GL_ARB_ES3_2_compatibility GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage GL_ARB_compute_shader GL_ARB_compute_variable_group_size GL_ARB_conditional_render_inverted GL_ARB_conservative_depth GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_derivative_control GL_ARB_direct_state_access GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_draw_indirect GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragment_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_shader GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader_int64 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_indirect_parameters GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multi_draw_indirect GL_ARB_occlusion_query2 GL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_object GL_ARB_point_sprite GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_query_buffer_object GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counter_ops GL_ARB_shader_atomic_counters GL_ARB_shader_bit_encoding GL_ARB_shader_clock GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_storage_buffer_object GL_ARB_shader_subroutine GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_barrier GL_ARB_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map_array GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_attrib_64bit GL_ARB_vertex_attrib_binding GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ATI_blend_equation_separate GL_ATI_texture_float GL_ATI_texture_mirror_once GL_EXT_abgr GL_EXT_blend_equation_separate GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_pixel_buffer_object GL_EXT_polygon_offset_clamp GL_EXT_provoking_vertex GL_EXT_shader_integer_mix GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_texture_shared_exponent GL_EXT_texture_snorm GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_EXT_window_rectangles GL_IBM_multimode_draw_arrays GL_KHR_context_flush_control GL_KHR_debug GL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_MESA_pack_invert GL_MESA_shader_integer_functions GL_MESA_texture_signed_rgba GL_NV_conditional_render GL_NV_depth_clamp GL_NV_packed_depth_stencil GL_NV_texture_barrier GL_NV_vdpau_interop GL_OES_EGL_image GL_S3_s3tc
WebGL 2 Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_texture_float_linear WEBGL_compressed_texture_etc WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
Audio Backend: pulse-rust
GPU #1
Active: Yes
Description: nouveau -- Gallium 0.4 on NVC1
Vendor ID: nouveau
Device ID: Gallium 0.4 on NVC1
Driver Version: 3.0 Mesa 17.1.4

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none
CairoUseXRender: 0
Device Reset: Trigger Device Reset
Decision Log
HW_COMPOSITING:
blocked by default: Acceleration blocked by platform
OPENGL_COMPOSITING:
unavailable by default: Hardware compositing is disabled
WEBRENDER:
opt-in by default: WebRender is an opt-in feature




Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 2
browser.places.smartBookmarksVersion: 8
browser.startup.homepage_override.buildID: 20170717100212
browser.startup.homepage_override.mstone: 56.0a1
browser.urlbar.lastSuggestionsPromptDate: 20170717
browser.urlbar.timesBeforeHidingSuggestionsHint: 0
extensions.lastAppVersion: 56.0a1
media.gmp-gmpopenh264.abi: x86_64-gcc3
media.gmp-gmpopenh264.lastUpdate: 1500325599
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20170717100212
media.gmp-manager.lastCheck: 1500325594
media.gmp.storage.version.observed: 1
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.16 Beta
Version in use: 4.16 Beta

NSS
Expected minimum version: 3.32 Beta
Version in use: 3.32 Beta

NSSSMIME
Expected minimum version: 3.32 Beta
Version in use: 3.32 Beta

NSSSSL
Expected minimum version: 3.32 Beta
Version in use: 3.32 Beta

NSSUTIL
Expected minimum version: 3.32 Beta
Version in use: 3.32 Beta

Experimental Features
---------------------

Sandbox
-------

Seccomp-BPF (System Call Filtering): true
Seccomp Thread Synchronization: true
User Namespaces: true
Content Process Sandboxing: true
Media Plugin Sandboxing: true
Content Process Sandbox Level: 2
Effective Content Process Sandbox Level: 2

Rejected System Calls
---------------------
Flags: needinfo?(bob)
Ah ha, thanks.  This looks like a separate issue, can you open a new bug on the component "Webextensions Untriaged" with the details from comment 24?
See Also: → 1381633
You need to log in before you can comment on or make changes to this bug.