Status

()

enhancement
P1
normal
Rank:
15
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: drno, Assigned: dminor)

Tracking

Trunk
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 years ago
Apparently AEC logging still fails to write log files if e10s is on.
So we should disable the button if e10s is on as long as we know that it's going to fail to write the requested log file.
Reporter

Comment 1

2 years ago
Even with e10s off it does not work. Sandbox?
Assignee

Updated

2 years ago
Assignee: nobody → dminor
Status: NEW → ASSIGNED
Rank: 15
Summary: Hide "Start AEC Logging" button under e10s → Fix AEC Logging
Sandbox isn't in effect for non-e10s.  Also fails in all cases on linux
Assignee

Comment 3

2 years ago
The problem was that the 'apm_debug_dump' variable was not being set in gyp.mozbuild. This wasn't as easy to notice as might be expected because even without this variable set, some files were being built with the logging enabled.

At the time I was updating the relevant code for branch 57 of webrtc.org we didn't have a working build and it wasn't possible for me to test my changes. Once a working build was available, I was focused on other things and forgot to go back and test the logging.

I'm guessing this regression would have been caught by the webrtc.org gtests if it weren't for this: http://searchfox.org/mozilla-central/rev/cef8389c687203085dc6b52de2fbd0260d7495bf/media/webrtc/trunk/gtest/moz.build#14 :/
Attachment #8886222 - Flags: review?(rjesup) → review+

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b230bd5c696b
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.