Closed Bug 1379887 Opened 2 years ago Closed 2 years ago

Don't clobber the value of mWillBuildScrollableLayer when we are building a display list for event handling

Categories

(Core :: Web Painting, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1408607

People

(Reporter: tnikkel, Assigned: tnikkel)

References

Details

Attachments

(1 file)

Matt debug this as causing a test failure with retained display lists. It might be causing other problems on central so I want to fix this on m-c.
Attached patch decideboolSplinter Review
Attachment #8885112 - Flags: review?(mstange)
Comment on attachment 8885112 [details] [diff] [review]
decidebool

Review of attachment 8885112 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/generic/nsGfxScrollFrame.cpp
@@ +3605,5 @@
>  
>    bool wasUsingDisplayPort = false;
>    bool usingDisplayPort = false;
>    nsIContent* content = mOuter->GetContent();
> +  usingDisplayPort = wasUsingDisplayPort = nsLayoutUtils::HasDisplayPort(content);

Please reorder this as follows:

nsIContent* content = mOuter->GetContent();
bool wasUsingDisplayPort = nsLayoutUtils::HasDisplayPort(content);
bool usingDisplayPort = wasUsingDisplayPort;
Attachment #8885112 - Flags: review?(mstange) → review+
Pushed by tnikkel@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bc4c5281f2c2
Don't clobber the value of mWillBuildScrollableLayer when we are building a display list for event handling. r=mstange
https://hg.mozilla.org/mozilla-central/rev/bc4c5281f2c2
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Depends on: 1381708
Depends on: 1383568
Depends on: 1385205
backed this out
https://hg.mozilla.org/integration/mozilla-inbound/rev/58ec9fceb4acff9dfbb798d9cf9a859af6295521
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla56 → ---
I ended up making all the changes I wanted to make here in different bugs. Bug 1408607 was one of them, but there were others.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1408607
You need to log in before you can comment on or make changes to this bug.