Firefox sometimes crashes when entering or exiting full-screen mode for videos with JAWS running

RESOLVED WORKSFORME

Status

()

P2
critical
RESOLVED WORKSFORME
a year ago
5 months ago

People

(Reporter: blindcomputerguy, Assigned: Jamie)

Tracking

({crash, stackwanted, steps-wanted})

54 Branch
crash, stackwanted, steps-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tbird crash], crash signature)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170628075643

Steps to reproduce:

Enter full-screen mode for videos on the web, & exit full screen mode.


Actual results:

Firefox will sometimes crash after entering or exiting full-screen mode for videos on some websites.


Expected results:

The video was supposed to enter or exit full-screen mode without crashing Firefox.

Updated

a year ago
Summary: Firefox xometimes crashes when entering or exiting full-screen mode for videos on some web sites. → Firefox sometimes crashes when entering or exiting full-screen mode for videos on some web sites.

Comment 1

a year ago
https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Flags: needinfo?(blindcomputerguy)
Keywords: crash
(Reporter)

Comment 2

a year ago
http://www.komando.com is an example of one of the web sites where entering & exiting full-screen mode for videos will sometimes cause Firefox to crash. It will also sometimes happen emidiatly after I start playing a video. This problem occurred after the latest update to Firefox.
Flags: needinfo?(blindcomputerguy)

Comment 3

a year ago
Please provide you on which page you are experiencing a crash, as well as copying bp- list from about:crashes and posting.
Flags: needinfo?(blindcomputerguy)
(Reporter)

Comment 4

a year ago
https://www.komando.com
Flags: needinfo?(blindcomputerguy)

Updated

a year ago
Has STR: --- → no
Keywords: stackwanted, steps-wanted
(Reporter)

Comment 5

a year ago
click on the full screen button on a video to enter full-screen mode, play the video, then press ESC to exit full-screen mode.

Comment 6

a year ago
(In reply to blindcomputerguy from comment #5)
> click on the full screen button on a video to enter full-screen mode, play
> the video, then press ESC to exit full-screen mode.

I don't know the location of this video.


Please provide the crash IDs if you have used Mozilla builds and submit reports with crash reporter.

Comment 7

a year ago
This issue is not reproducible for me with the mentioned STR (in comment 4 & 5) and following user agent:

User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

Please provide crash ID from about:crashes

Get more info here: https://developer.mozilla.org/en-US/docs/Mozilla/How_to_get_a_stacktrace_for_a_bug_report

Comment 8

a year ago
It crashes sometimes when I exit from the full screen but not always crashes.

Comment 9

a year ago
Unfortunately we won't be able to do much without crash report as we are not able to reproduce the issue on our side. As a another check I would request you to create a new profile in Firefox (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems?redirectlocale=en-US&redirectslug=Basic+Troubleshooting#w_6-create-a-new-firefox-profile) and verify if problem persists with fresh profile and in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode?redirectlocale=en-US&redirectslug=Safe+Mode).

Our Firefox 55 is now released too. Check if you encounter this issue with Fx55 too. If yes I would highly request you to provide crash ID. Without crash ID we can't look into the root cause of issue. Let us know your finding. Thanks!
Flags: needinfo?(blindcomputerguy)
(Reporter)

Comment 10

a year ago
Report id: bp-ce5b26da-fadf-409f-bcbb-689471170810

How do I send you a crash report? I have several in about:crashes.
Flags: needinfo?(blindcomputerguy)

Comment 11

a year ago
Thanks for providing crash ID. It links to the crash report. So you don’t need to take any further action if you are sure that this crash id was encountered for this specific issue.
 
In your about:crashes there could be different crash ids, which may not be related to this issue. But if you are sure of a/multiple specific crash (es) that you got with your STR mentioned in your bug report then you can paste those id's here. 
 
Usually after crash, you get an option to submit crash report and it appears under submitted section in about:crashes with timestamp after you submit in otherwise it shows under un-submitted section.
 
In case you are not sure about the crash id and its cause, please try to duplicate the problem and once it crashes, you will get a new crash id at the top with the timestamp. Please provide us this new crash id to us.
I am changing this bug status to new so that dev can look into it.
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true

Comment 13

a year ago
The crash stacks match those of bug 1367715, which is fixed in 55, and is correlated with accessibility software, which given your bugzilla alias seems very very likely. Try updating to 55 (current release - https://www.mozilla.org/en-US/firefox/all/ ) and seeing if it still reproduces?
Blocks: 1367715
Component: General → Disability Access APIs
Flags: needinfo?(blindcomputerguy)
Product: Firefox → Core
(Reporter)

Comment 14

a year ago
Bug still exists in Firefox 55.

bp-6ac3fd47-8e45-499d-8e85-1d76e1170815
Flags: needinfo?(blindcomputerguy)
(In reply to :Gijs from comment #13)
> The crash stacks match those of bug 1367715, which is fixed in 55, and is
> correlated with accessibility software, which given your bugzilla alias
> seems very very likely. Try updating to 55 (current release -
> https://www.mozilla.org/en-US/firefox/all/ ) and seeing if it still
> reproduces?

Yes, there are JAWS modules in there. Aaron, any idea why this might still be happening despite the fix for bug 1367115?
Flags: needinfo?(aklotz)
Crash Signature: [@ NS_CycleCollectorSuspect3]
Can anyone recreate this bug in Firefox nightly? https://www.mozilla.org/en-US/firefox/channel/desktop/#nightly
Priority: -- → P2
That other bug was e10s-specific, this is not.

The problem in this bug is that JAWS is trying to manipulate a11y objects off the main thread (notice that the crashing thread is running FullscreenTransitionThreadProc).

We should probably look and see what is going on there to determine whether this is our fault or a bug in JAWS.
Flags: needinfo?(aklotz)
(In reply to |||PTO||| Aaron Klotz [:aklotz] from comment #18)
> That other bug was e10s-specific, this is not.
> 
> The problem in this bug is that JAWS is trying to manipulate a11y objects
> off the main thread (notice that the crashing thread is running
> FullscreenTransitionThreadProc).
> 
> We should probably look and see what is going on there to determine whether
> this is our fault or a bug in JAWS.

looping in Jamie, Jamie says that shouldn't happen in the wild, and if it is, then it's JAWS bug
(Assignee)

Updated

6 months ago
Duplicate of this bug: 1395104
(Assignee)

Comment 21

6 months ago
Crash stack for 59 that hasn't been deleted (thanks Alex): bp-ad709c71-fb57-41c9-a752-239580180321
FSDomNodeIAText.DLL version: 10.3.17.0
jhook.dll version: 19.3.17.0
(Assignee)

Comment 22

5 months ago
I was able to reproduce this myself. bp-5e071755-7601-48dd-a4dd-7dc990180417
I had to use Firefox 52, as the same STR causes a Stylo crash in Nightly which I'm going to need to dig into separately. However, I suspect we may see this crash again once the Stylo crash is dealt with.

STR (with Firefox 52):
1. Open this page: https://developer.mozilla.org/samples/domref/fullscreen.html
2. With the document focused, press JAWSKey+3 to pass key through, then press enter. This toggles full screen.
3. Repeat step 2 a few times.
4. If it doesn't crash, try pressing alt+d to focus the address bar (when not in full screen), then move focus back to the document. You may also need to alt+tab a bit. Then, keep trying step 2.
It's sometimes a little tricky, but you should be able to reproduce it with a few tries and some fiddling.

We create an HWND off the main thread for DOM full screen transitions. When we destroy the window in FullscreenTransitionThreadProc, that causes Windows to fire a destroy win event, which in turn causes JAWS to try to call a method on some object. I'm working with VFO (the vendor for JAWS) to try to track this down.
Assignee: nobody → jteh
(Assignee)

Updated

5 months ago
Summary: Firefox sometimes crashes when entering or exiting full-screen mode for videos on some web sites. → Firefox sometimes crashes when entering or exiting full-screen mode for videos with JAWS running

Comment 23

5 months ago
A couple different crash signatures that mention JAWS
 fsdomsrv.dll@0x59350  bp-c6d2bde2-2405-4be4-8108-7400f0180308
 style::style_resolver::StyleResolverForElement<T>::match_primary<T>  bp-d6483f92-879e-4263-a358-ac8f50180306
 uiautomationcore.dll@0x4124d  bp-33024136-e60a-49e7-8cb7-c7ef60180209
Whiteboard: [tbird crash]
(Assignee)

Comment 24

5 months ago
(In reply to Wayne Mery (:wsmwk) from comment #23)
> A couple different crash signatures that mention JAWS
>  style::style_resolver::StyleResolverForElement<T>::match_primary<T> 
> bp-d6483f92-879e-4263-a358-ac8f50180306

This one is covered (and fixed) by bug 1454572. I'm not sure about the other two.

(In reply to James Teh [:Jamie] from comment #22)
> I was able to reproduce this myself. bp-5e071755-7601-48dd-a4dd-7dc990180417
> I had to use Firefox 52, as the same STR causes a Stylo crash in Nightly
> which I'm going to need to dig into separately.

That's bug 1454572, now fixed.

> However, I suspect we may
> see this crash again once the Stylo crash is dealt with.

I can't reproduce the crash in this bug any more, even with the style crash fixed. So, I'm closing this as worksforme. This is unfortunate for ESR 52, but we're pretty close to ESR 60 anyway. Also, this is JAWS calling us on the wrong thread, so there's probably not much we can do to fix it even in ESR 52.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.