Closed Bug 1379928 Opened 4 years ago Closed 4 years ago

NS_ERROR_DOM_MEDIA_FATAL_ERR

Categories

(Core :: Audio/Video: Playback, defect, P1)

56 Branch
Unspecified
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1397141

People

(Reporter: sviter33, Assigned: alwu)

References

Details

(Keywords: stale-bug)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170710030203

Steps to reproduce:

Go to https://twitter.com/xeBuz/status/884366419907031040


Actual results:

gif dosen't play. In console I can see https://video.twimg.com/tweet_video/DEXmdlBWsAAfKY8.mp4, error: Error Code: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005)
Details: error creating audio decoder


Expected results:

gif should play
Component: Untriaged → Audio/Video: Playback
OS: Unspecified → Windows 10
Product: Firefox → Core
WFM on Mac OSX. According to ffprobe there's no audio track:

Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'DEXmdlBWsAAfKY8.mp4':
  Metadata:
    major_brand     : mp42
    minor_version   : 0
    compatible_brands: mp42mp41isom
    creation_time   : 2017-07-10 10:59:18
  Duration: 00:00:08.12, start: 0.000000, bitrate: 13 kb/s
    Stream #0:0(und): Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuv420p, 188x34, 11 kb/s, 14.41 fps, 14.29 tbr, 1k tbn, 2k tbc (default)
    Metadata:
      creation_time   : 2017-07-10 10:59:18
      handler_name    : Twitter v1.0-757770b7c8e9d79a526cdff77e74666386274fdf
      encoder         : AVC Coding
Priority: -- → P1
This is a P1 bug without an assignee. 

P1 are bugs which are being worked on for the current release cycle/iteration/sprint. 

If the bug is not assigned by Monday, 28 August, the bug's priority will be reset to '--'.
Keywords: stale-bug
CAN reproduce this issue on Win7 with Beta 56.0b8 and Nightly 57.0a1 (2017-09-03).

CAN NOT reproduce this issue on OSX 10.11.4 with Nightly 57.0a1 (2017-09-03).
I'll investigate this issue.
Assignee: nobody → alwu
OS: Windows 10 → Windows
I would mark this bug as invalid, because the resolution of that video (188x34) is unsupported by WMF, the minimum resolution is 48x48 [1].

However, the error message is wrong, it shows "Details: error creating audio decoder". In order to show the correct error description, I would fix it in bug1397141.

[1] https://msdn.microsoft.com/en-us/library/windows/desktop/dd797815(v=vs.85).aspx
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
See Also: → 1397141
I wouldn't say it's invalid.

It's just something we can't support.

WONTFIX is a better resolution

However, it's also very likely that this video will play if we didn't attempt to use the HW decoder for such small videos (which is what made use stop supporting those videos)

This will be addressed in bug 1392143.  Where we will never attempt to use the HW decoder for resolution with width or height <= 128 pixels

So will revisit this bug once bug 1392143 lands
Status: RESOLVED → REOPENED
Depends on: 1392143
Resolution: INVALID → ---
If I remember correctly, we could only use WMF to decode h264 on Windows, right?
The resolution constraint is for WMF software decoder, so I don't understand why it would be related with hardware decoder.

If I'm wrong, please correct me, thanks.
Flags: needinfo?(jyavenard)
While the constraint is documented for the entire H264 MFT, that's likely only because of hardware limitations. The software decoder have no such limitations, it is not bound to minimal surface size.
Flags: needinfo?(jyavenard)
(In reply to Jean-Yves Avenard [:jya] from comment #8)
> While the constraint is documented for the entire H264 MFT, that's likely
> only because of hardware limitations. The software decoder have no such
> limitations, it is not bound to minimal surface size.

I've tested my own build without the resolution constraint, yes, it can work! The MFT software decoder can play this video successfully. Therefore, I have some questions.

(1) Why software decoder doesn't have resolution constraint? What's the main reason?

(2) Does software decoder still have the maximum resolution limitation?

(3) What's the maximum resolution limitation for software decoder? Is it as same as hardware decoder?
    eg. above win7 and win7 with platform update (KB2670838) can support 4K, otherwise it's not 4k capable

(4) If we would automatically fall back to software decoder when hardware decoder fails, it that mean adding the resolution constrain is wrong? Should we remove resolution constraint from WMFDecoderModule and WMFVideoMFTManager?

Thanks!
Flags: needinfo?(jyavenard)
1) why would they have a resolution constraint? They are decoding a perfectly valid streams. Hardware have technical constraints. For more information you would have to ask microsoft.

2) I don't think so either, except it becomes exponentially slower.

3) The D3D11 may have a maximum size it can render

4) when the HW decoder isn't in use, yes, I think we should remove those constraints.
Flags: needinfo?(jyavenard)
Thanks for your reply.
This issue would have a easy fix by removing the resolution constraint (bug1397141) or by disabling hardware decoding for small videos (bug 1392143).
We could close this bug after landing them.
This issue is fixed by bug1397141, we remove the minimum resolution constraint. 
Now this video can be playback via software decoder.

Test on Nightly 57.0a1 (2017-09-13), the issue was gone.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1397141
You need to log in before you can comment on or make changes to this bug.