All users were logged out of Bugzilla on October 13th, 2018

Invalid URL message received when tapping on 'Go to copied link' from Today Widget on iOS 10.2

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: SimonB, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios-v8.0 affected, fxios-v9.0 affected)

Details

(Whiteboard: [MobileCore][Regression], URL)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Build: 8.0
Device: iPad Pro
iOS 10.2.1

Steps to reproduce:
1. Copy a link to clipboard
2. Swipe down to open Widget screen
3. Tap on 'Go to copied link' from Today Widget

Actual results:
- Invalid URL message is displayed and the URL is incorrect. The dot '.' in the URL is converted to '%2e'.

Note:
- Reproduced this only on iPad Pro.
- Last build that worked was Beta 3991. After build 3991 this build the Widget was broken.
(Reporter)

Comment 1

a year ago
Created attachment 8885265 [details]
IMG_0005.PNG
(Reporter)

Updated

a year ago
(Reporter)

Comment 2

a year ago
This is an iOS 10.2 issue. I manage to reproduce this issue in the simulator using iOS 10.2. This is not reproducible on iOS 10.3 in the simulator or on actual device.
Summary: Invalid URL message received when tapping on 'Go to copied link' from Today Widget on iPad Pro → Invalid URL message received when tapping on 'Go to copied link' from Today Widget on iOS 10.2
This actually might be a case of multiple versions of the fennec being installed. The Today widget might be opening the wrong fennec app.

Try removing every version of fennec/firefox and make sure the Today extensions are also gone.
Flags: needinfo?(simion.basca)
(Reporter)

Comment 4

a year ago
I tested this issue with only one build, beta 8.04467 on iPad Pro running ios 10.2.1.
I also managed to reproduce this issue in the simulator on iOS 10.2. Also tested in the simulator on iOS 10.3 and on actual device and it is not reproducible.
Flags: needinfo?(simion.basca)
Whiteboard: [MobileCore][Regression]
Smells like WONTFIX if it's fixed on 10.3+
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
tracking-fxios: ? → ---
You need to log in before you can comment on or make changes to this bug.