Linking to blob: URLs broken from extension pages

RESOLVED DUPLICATE of bug 1331176

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1331176
4 months ago
4 months ago

People

(Reporter: Wladimir Palant (for Adblock Plus info Cc bugzilla@adblockplus.org), Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: investigate)

Attachments

(1 attachment)

Created attachment 8885226 [details]
test.xpi

Steps to reproduce:

1. Go to about:debugging and install this extension as a temporary add-on.
2. Go to about:addons, find "WebExtensions test" in the list and click Preferences.
3. Click "Click here to open a blob: URL" link on the options page (linking to a blob:moz-extension:// URL).

Expected results:

The blob URL opens and JSON viewer kicks in. This is what happens if you open the same page via a file:/// URL or if you middle-click the link to open it in a new tab.

Actual results:

The page turns blank without changing URL in the location bar, the load indicator keeps spinning forever. I've tested in Firefox 56.0a1 nightly (2017-07-11) on Ubuntu.

This is very similar to bug 1303868, but with the steps listed there the issue is not reproducible for me.

Updated

4 months ago
Flags: needinfo?(mixedpuppy)
Whiteboard: investigate
Flags: needinfo?(mixedpuppy)
See Also: → bug 1331176
This still fails with extensions.webextensions.remote=false, but works with extensions.webextensions.remote=true, not certain it's worth addressing since default will become remote.
I used the test addon from bug 1331176 to test in the sidebar and a tab (browserAction button opens the page in a tab).
Verified test with addon attached here as well, same results.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1331176
You need to log in before you can comment on or make changes to this bug.