Latin characters are messed up on website

RESOLVED DUPLICATE of bug 1382260
(NeedInfo from)

Status

()

Core
Graphics: Text
RESOLVED DUPLICATE of bug 1382260
a year ago
10 months ago

People

(Reporter: hibatsu, Unassigned, NeedInfo)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted)

Attachments

(3 attachments)

(Reporter)

Description

a year ago
Created attachment 8885238 [details]
Bildschirmfoto 2017-07-11 um 11.52.55.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170710100238

Steps to reproduce:

1. Visit https://uxchecklist.github.io/
2. See the messed-up characters

Might be related to the font-stack used on the page:
'Open Sans', "HelveticaNeue-Light", "Helvetica Neue Light", "Helvetica Neue", Helvetica, Arial, "Lucida Grande", sans-serif

Doesn't happen in any other browser, including FF Dev Edition.

(nightly-community)


Actual results:

Text is illegible


Expected results:

Font should be rendered correctly
(Reporter)

Comment 1

a year ago
Created attachment 8885239 [details]
Bildschirmfoto 2017-07-11 um 14.37.52.png

This is on OSX (10.12.5).
I just saw that this even happens on this very page as well for the arrow icons.
works for me, on 56.0a1 (2017-07-11) (64-bit) on macOS 10.12.5.

can you check what font is actually used there, by right-click on the text and "Inspect Element", and check "Font" tab?
for me, "Helvetica Neue Light" is used in the comment #0 case,
and "Lucida Grande" is used on the comment #1 case
Flags: needinfo?(hibatsu)
(Reporter)

Comment 3

a year ago
I'm getting, both on the ux-checklist as well as this page:

.LastResort system
Used as: "Open Sans"
Flags: needinfo?(hibatsu)
moving to possibly corresponding component.

meanwhile, can you check when the issue started happening, by using mozregression tool?
http://mozilla.github.io/mozregression/
Component: Untriaged → Graphics: Text
Product: Firefox → Core
(In reply to hibatsu from comment #3)
> I'm getting, both on the ux-checklist as well as this page:
> 
> .LastResort system
> Used as: "Open Sans"

That's definitely broken in some way, but it's not clear to me what has gone wrong.

Do you have Open Sans fonts installed on your system? What Open Sans font files, exactly?
Flags: needinfo?(hibatsu)
(Reporter)

Comment 6

a year ago
Yes, I have some Open Sans weights installed:
Light
Regular
Semibold
Bold

As far as I can tell I downloaded them from google fonts.
Flags: needinfo?(hibatsu)
(Reporter)

Comment 7

a year ago
Created attachment 8885270 [details]
OpenSans.zip

I've attached the font weights in question.
(Reporter)

Comment 8

a year ago
Interestingly enough, if I disable them, the pages look fine.
Thanks for the reply. That's both interesting and strange...
Looks like the same version of Open Sans as I have installed on my MacBook Pro, but I don't see the bug here. (I have a more complete set of weights/styles, but I tried enabling only those 4 fonts, and the problem still doesn't happen for me.)

Puzzling.
I've installed font file from Comment 7 and cannot reproduce the problem.
Jonathan, are you still investigating on this bug, do you have any idea about this?
Flags: needinfo?(jfkthame)
I wonder if this is related to the use of a font manager (like FontExplorerX) and the sandbox; see bug 1382260.

hibatsu, do you use a font management utility? If you set security.sandbox.content.level to 1 in about:config and restart the browser, does this fix the problem?
Flags: needinfo?(jfkthame) → needinfo?(hibatsu)
hibatsu, if you run the tryserver build of Nightly from https://treeherder.mozilla.org/#/jobs?repo=try&revision=355c420847057affe4bfa709375c6b3887ad616a (see [1] for the actual download), does this solve the problem (without altering sandbox settings)?

[1] https://queue.taskcluster.net/v1/task/cC1NN-08SMagaAKIQDSv2g/runs/0/artifacts/public/build/target.dmg
Whiteboard: gfx-noted

Comment 15

11 months ago
(In reply to Jonathan Kew (:jfkthame) from comment #13)
> I wonder if this is related to the use of a font manager (like
> FontExplorerX) and the sandbox; see bug 1382260.
> 
> hibatsu, do you use a font management utility? If you set
> security.sandbox.content.level to 1 in about:config and restart the browser,
> does this fix the problem?

I can confirm that this fixes the problem for me. (And yes, I use FontExplorerX.)
Thanks for this, it's good to have this confirmed.

Could you please try something further? Set the sandbox level back to 3 (so that the problem reappears), and then see what sandbox violations are reported in the system console. See bug 1382260 comment 14 for details of how to enable sandbox logging via about:config in Nightly, and how to view the messages in Console.app.
Flags: needinfo?(ethanmarcotte)

Comment 17

10 months ago
(In reply to Jonathan Kew (:jfkthame) from comment #16)
> Thanks for this, it's good to have this confirmed.
> 
> Could you please try something further? Set the sandbox level back to 3 (so
> that the problem reappears), and then see what sandbox violations are
> reported in the system console. See bug 1382260 comment 14 for details of
> how to enable sandbox logging via about:config in Nightly, and how to view
> the messages in Console.app.

Done and done! Got a whole host of log errors in Console.app:

```
error	18:59:29.565580 -0400	plugin-container	Failed to create communication port for com.apple.CFPasteboardClient; this is likely due to sandbox restrictions
default	18:59:29.575414 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Applications
default	18:59:29.575710 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Applications
default	18:59:29.811391 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.811421 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.811441 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
default	18:59:29.811459 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.811469 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.811478 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
default	18:59:29.811665 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) mach-lookup com.apple.system.logger
default	18:59:29.812110 -0400	plugin-container	FolderManager: Failed looking up user domain root; url='file://localhost/Users/username/' path=/Users/username/ err=-120 uid=501 euid=501
default	18:59:29.812209 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812226 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812239 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
default	18:59:29.812252 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812262 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812270 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
default	18:59:29.812351 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812361 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812371 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
default	18:59:29.812390 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812399 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812408 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
default	18:59:29.812484 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812494 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812503 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
default	18:59:29.812292 -0400	plugin-container	FolderManager: Failed looking up user domain root; url='file://localhost/Users/username/' path=/Users/username/ err=-120 uid=501 euid=501
default	18:59:29.812513 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812426 -0400	plugin-container	FolderManager: Failed looking up user domain root; url='file://localhost/Users/username/' path=/Users/username/ err=-120 uid=501 euid=501
default	18:59:29.812547 -0400	plugin-container	FolderManager: Failed looking up user domain root; url='file://localhost/Users/username/' path=/Users/username/ err=-120 uid=501 euid=501
default	18:59:29.812524 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username
default	18:59:29.812532 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
default	18:59:29.812596 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Applications
default	18:59:29.812605 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Applications
default	18:59:29.812614 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Applications
default	18:59:29.812631 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Applications
default	18:59:29.812640 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Applications
default	18:59:29.812647 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Applications
default	18:59:31.549228 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) file-read-metadata /Applications
default	18:59:31.712039 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) mach-register com.apple.axserver
default	18:59:31.716293 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) mach-lookup com.apple.touchbar.agent
default	18:59:31.730215 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) mach-register com.apple.tsm.portname
default	18:59:31.731164 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) mach-register com.apple.CFPasteboardClient
error	18:59:31.731306 -0400	plugin-container	Failed to create communication port for com.apple.CFPasteboardClient; this is likely due to sandbox restrictions
default	18:59:31.735284 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) file-read-metadata /Applications
default	18:59:31.735333 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) file-read-metadata /Applications
default	18:59:31.735369 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) file-read-metadata /Applications
default	18:59:31.735471 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) file-read-metadata /Applications
default	18:59:31.735708 -0400	kernel	SandboxViolation: plugin-container(93187) deny(1) file-read-metadata /Applications
default	18:59:33.119710 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username/Dropbox/Fonts/_library/I/Inconsolata/Inconsolata.otf
default	18:59:33.119734 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username/Dropbox/Fonts/_library/I/Inconsolata/Inconsolata.otf
default	18:59:33.119747 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
default	18:59:33.122796 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username/Dropbox/Fonts/_library/I/Inconsolata/Inconsolata.otf
default	18:59:33.122828 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username/Dropbox/Fonts/_library/I/Inconsolata/Inconsolata.otf
default	18:59:33.122863 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users
```
Thanks! I don't know what many of these are about, but the most interesting thing there, I think, is the mention of

default	18:59:33.119710 -0400	kernel	SandboxViolation: plugin-container(93149) deny(1) file-read-metadata /Users/username/Dropbox/Fonts/_library/I/Inconsolata/Inconsolata.otf

I assume Inconsolata is a font you have activated with FontExplorerX, and this confirms that such fonts may be located pretty much anywhere you may have chosen to keep them (this looks like it's stored in a Fonts library that you manage with Dropbox, presumably to sync it between multiple systems). There's no standard "FontExplorerX font directory" that we can simply whitelist to allow access through the sandbox.

I'm going to mark this as a duplicate of bug 1382260, as it's the same problem being discussed there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1382260
(Reporter)

Comment 19

10 months ago
Sorry for the late response and thank you beep for confirming.

Just to add: The issue is not limited to FontExplorerX, I'm using RightFont (https://rightfontapp.com/).
Flags: needinfo?(hibatsu)
(In reply to hibatsu from comment #19)
> Sorry for the late response and thank you beep for confirming.
> 
> Just to add: The issue is not limited to FontExplorerX, I'm using RightFont
> (https://rightfontapp.com/).

Interesting; I wasn't aware of that utility, so thanks for pointing it out.
You need to log in before you can comment on or make changes to this bug.