Closed Bug 1379976 Opened 3 years ago Closed 3 years ago

New Mail Account wizard doesn't allow setup of .academy mail address

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 59.0

People

(Reporter: nONoNonO, Assigned: aceman)

References

()

Details

Attachments

(1 file)

In sumo a question was asked about account setup for an .academy account:https://support.mozilla.org/en-US/questions/1167346

Looking at the source code https://dxr.mozilla.org/comm-central/source/mail/components/accountcreation/content/emailWizard.js#36 there's some fuzzy logic as to how an email address should look like, where the last part is limited to 6 characters. However, looking at https://en.wikipedia.org/wiki/List_of_Internet_top-level_domains#Brand_top-level_domains there are much longer top level domains, of up to 15 characters.

The code should be changed to allow to setup an email address for these accounts as well.
Summary: New Mail Account wizard doesn't allow setup of .academy mali address → New Mail Account wizard doesn't allow setup of .academy mail address
Something for Aceman to look into.
Flags: needinfo?(acelists)
See Also: → 1383433
Yeah, the mess with allowing any top level domains...

So let's expand the regex.
Assignee: nobody → acelists
Flags: needinfo?(acelists)
I've tried it entering .academy email into the account creation wizard. There is the "Double check this email address" warning, but it does not prevent continuing in the wizard. I did create such an account successfully.
BenB, do you think we should loosen the regex to allow any string in the top level domain, or we can live with the warning for people having one of the new long top level domains?
Flags: needinfo?(ben.bucksch)
It's this glibberish of regexp:
var emailRE = /^[-_a-z0-9\'+*$^&%=~!?{}]+(?:\.[-_a-z0-9\'+*$^&%=~!?{}]+)*@(?:[-a-z0-9.]+\.[a-z]{2,6}|\d{1,3}(?:\.\d{1,3}){3})(?::\d+)?$/i;
https://dxr.mozilla.org/comm-central/source/mail/components/accountcreation/content/emailWizard.js#36
https://dxr.mozilla.org/comm-central/source/mail/components/accountcreation/content/emailWizard.js#429

Yeah, let's fix the regexp.
Flags: needinfo?(ben.bucksch)
Duplicate of this bug: 1383433
Attached patch 1379976.patchSplinter Review
OK, I increased it to 20 for some future-proofness ;)
Attachment #8933038 - Flags: review?(ben.bucksch)
Comment on attachment 8933038 [details] [diff] [review]
1379976.patch

r+
Attachment #8933038 - Flags: review?(ben.bucksch) → review+
Thanks.
Status: NEW → ASSIGNED
Keywords: checkin-needed
OS: Unspecified → All
Hardware: Unspecified → All
Version: unspecified → Trunk
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/8cd26835235c
allow longer top level domains in account wizard. r=BenB
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 59.0
You need to log in before you can comment on or make changes to this bug.