Closed Bug 1379997 Opened 3 years ago Closed 3 years ago

MS-IME input mode notification stops working on Windows10 Creators Update

Categories

(Core :: Widget, defect)

56 Branch
Unspecified
Windows 10
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- wontfix
firefox54 --- wontfix
firefox55 + fixed
firefox56 + fixed

People

(Reporter: alice0775, Assigned: masayuki)

Details

(Keywords: inputmethod, jp-critical, regression, Whiteboard: [DUPEME][Regressed by Bug 1367692])

Attachments

(2 files)

[Tracking Requested - why for this release]: MS-IME input mode notification stops working

Reproducible: always

Steps To Reproduce:
1. Enable MS-IME
2. Toggle input mode from ひらがな to 直接入力 and vice versa


Actual Results:
No notification pops up at the center of screen

IME mode Notification[あ]/[A] should popup at the center of screen


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=38e06c672764234f76bd25fb482b58c640f09e1b&tochange=fd35e2ebf019d75c648d8ec5663bf58f1a444621

Regressed by: fd35e2ebf019	Masayuki Nakano — Bug 1367692 - Make IMEHandler not restore default IMC unless legacy IMM-IME is active. r=m_kato
Flags: needinfo?(masayuki)
[Tracking Requested - why for this release]:
Ah, thanks. So, disassociating IMC from the window hits a bug of TSF or MS-IME. We should disable the fix with pref.
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Flags: needinfo?(masayuki)
Track 55+/56+ as regression in MS-IME input mode notification.
I think that only part1 should be uplifted if it's possible (for risk management).
Comment on attachment 8892059 [details]
Bug 1379997 - part1: Disable "intl.tsf.hack.ms_japanese_ime.do_not_associate_imc_on_win10" pref in default settings

https://reviewboard.mozilla.org/r/163070/#review168570
Attachment #8892059 - Flags: review?(m_kato) → review+
Comment on attachment 8892060 [details]
Bug 1379997 - part2: Remove "intl.tsf.hack.ms_japanese_ime.do_not_associate_imc_on_win10" pref completely

https://reviewboard.mozilla.org/r/163072/#review168572

We need investigate CTipFnHotkeyManager related crash with MS team ...
Attachment #8892060 - Flags: review?(m_kato) → review+
(In reply to Makoto Kato [:m_kato] from comment #10)
> We need investigate CTipFnHotkeyManager related crash with MS team ...

I heard that this crash has already been fixed at Build 16215 (will be in Fall Creators Update, won't be ported to Creators Update, though).
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/5c312f2c6e58
part1: Disable "intl.tsf.hack.ms_japanese_ime.do_not_associate_imc_on_win10" pref in default settings r=m_kato
https://hg.mozilla.org/integration/autoland/rev/1b823be2a09f
part2: Remove "intl.tsf.hack.ms_japanese_ime.do_not_associate_imc_on_win10" pref completely r=m_kato
Comment on attachment 8892059 [details]
Bug 1379997 - part1: Disable "intl.tsf.hack.ms_japanese_ime.do_not_associate_imc_on_win10" pref in default settings

Approval Request Comment
[Feature/Bug causing the regression]:
Regression of bug 1367692 (Although, this is also a bug of MS-IME for Japanese, and I've already reported this bug to them and confirmed by them).

[User impact if declined]:
Cannot see input mode with popup.

[Is this code covered by automated tests?]:
No.

[Has the fix been verified in Nightly?]:
Not yet, it'll be included in next build.

[Needs manual test from QE? If yes, steps to reproduce]:
No.

[List of other uplifts needed for the feature/fix]:
No.

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
This patch just disables the hack added by bug 1367692. Note that the hack failed to avoid the crash of MS-IME for Japanese. And the crash report rate isn't changed. So, we can just disable the hack by this pref change.

[String changes made/needed]:
No.
Attachment #8892059 - Flags: approval-mozilla-beta?
We don't need to uplift part2 since it removes the hack and pref but we don't need to do it in the branches.
Comment on attachment 8892059 [details]
Bug 1379997 - part1: Disable "intl.tsf.hack.ms_japanese_ime.do_not_associate_imc_on_win10" pref in default settings

ok let's take this one patch for 55 build2
Attachment #8892059 - Flags: approval-mozilla-beta? → approval-mozilla-release+
No need for manual testing based on comment 14. Setting qe-verify-
Flags: qe-verify-
I have a hard time imagining that this issue is severe enough for our ESR52 user population to warrant backport consideration there. Feel free to set it back to affected and nominate for approval if you feel otherwise, though.
(In reply to Ryan VanderMeulen [:RyanVM] from comment #19)
> I have a hard time imagining that this issue is severe enough for our ESR52
> user population to warrant backport consideration there. Feel free to set it
> back to affected and nominate for approval if you feel otherwise, though.

If only small number of Japanese users use ESR52, it's not problem. Otherwise, I still think that we should disable the new hack by the pref. It might be annoying for MS-IME for Japanese users. First, IME has "open/closed" state. That is changed with "Hankaku/Zenkaku" key or Alt + '`' key. So, it's toggled by a key (combination). Users can confirm if the state is changed to expected "open/closed" state with the notification. In other words, when user type a character, users may realize that the state is unexpected after toggling the state. So, this may be annoying.
You need to log in before you can comment on or make changes to this bug.