Crash during session restoration on 54.0.1

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: ron190, Unassigned)

Tracking

({crash})

54 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161019084923

Steps to reproduce:

Update to 54.0.1, then restart Firefox


Actual results:

Firefox starts, tabs are loading then the crash occurs every time I restart Firefox.


Expected results:

Tabs should load like it does correctly on Firefox 49 (I downgraded to retreive my tabs).
Note: I have a lot of tabs, but it works like a charm until 54.0.1.

Comment 1

a year ago
https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Component: Untriaged → Session Restore
Flags: needinfo?(ron190)
Keywords: crash, stackwanted

Comment 3

a year ago
bp-572644c4-37ee-4638-9244-a70c40170711 is Firefox 54 only.

You have many add-ons enabled, please try Restart with Disabled add-ons (safe mode) or clean profile to reproduce.
Crash Signature: [@ js::jit::JitFrameIterator::machineState ]
Keywords: stackwanted
(Reporter)

Comment 4

a year ago
I disabled all add-ons and it's loading correctly.

I have re-enabled some add-ons and it crashed again, then I played with enabling/disabling more add-ons again and now it works.

I can't reproduce the crash, this can be closed for now I think.

Comment 5

a year ago
Reopen if you find more info.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: Session Restore → General
Resolution: --- → WORKSFORME
Version: 49 Branch → 54 Branch
You need to log in before you can comment on or make changes to this bug.