Closed Bug 138022 Opened 20 years ago Closed 20 years ago

need confirmation when closing the last window and exiting

Categories

(SeaMonkey :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 39057

People

(Reporter: sds, Assigned: Matti)

Details

I want an option to ask for a confirmation when exiting moz.
on win32 there is "quick launch" which does that, but on unix there is no way to
prevent me from accidentally exiting moz by closing the last window.
Why do you want this ?
Just restart mozilla...
found it....

see bug 57755

*** This bug has been marked as a duplicate of 39057 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
restart doesn't cut it: I will have to re-enter the password and re-login to all
the sites I was using.  I will lose the browing history.
In Emacs, C-x C-c asks for a confirmation.
I want Mozilla to do the same.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
this is a dupe, your request is indeed covered by that bug.

you didn't ask for quick launch for linux (there's a bug for that), you asked 
for a confirmation dialog on exit.

anyways, if you want quicklaunch, get yourself a good debugger (e.g. dbx), run 
mozilla in it. when you quit mozilla, you'll end up in the debugger, and you 
can instruct the debugger to run mozilla again. If you're using a good debugger 
(dbx) the libraries will still be loaded so mozilla will start quickly.

please don't reopen bugs without taking the time to read the bug against 
which they are duped.

*** This bug has been marked as a duplicate of 39057 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.