No newaddon tab if WebExtension added globaly in winreg

VERIFIED DUPLICATE of bug 1372448

Status

()

VERIFIED DUPLICATE of bug 1372448
a year ago
a year ago

People

(Reporter: crasniy_bugatty, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36

Steps to reproduce:

1. Add webextension name, path in windows registry in HKLM\Software\Mozilla\Firefox\Extensions (as described at https://developer.mozilla.org/en-US/Add-ons/Adding_extensions_using_the_Windows_registry)
2. Run firefox


Actual results:

Firefox opened with blank page


Expected results:

Opened about:newaddon?id=<id>
(Reporter)

Comment 1

a year ago
In AddonManager extension has added and disabled
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit
We got rid of the about:newaddon flow in bug 1317363.  Do you see the new indicator on the hamburger menu?
Flags: needinfo?(crasniy_bugatty)
(Reporter)

Comment 3

a year ago
I don't see any notification or indication. Hamburger not changed during browser start
Flags: needinfo?(crasniy_bugatty)
(Reporter)

Comment 4

a year ago
Created attachment 8886063 [details]
1.webm

Bug repro video

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1372448
Component: WebExtensions: General → Add-ons Manager
(Reporter)

Updated

a year ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.