Closed Bug 1380266 Opened 3 years ago Closed 3 years ago

[Android O] Inconsistency at Back from Settings SubMenu

Categories

(Firefox for Android :: Settings and Preferences, defect, P1)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
fennec + ---
firefox55 --- wontfix
firefox56 --- verified
firefox57 --- verified

People

(Reporter: ioana.chiorean, Assigned: jwu)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [FNC][SPT57.3][INT])

Attachments

(1 file)

Nexus 6P - Android O 

Steps:
1. Go to a submenu in Settings ( Settings -> Privacy fro ex) 
2. Tap the back button from top  left corner 

Expected results:
- like on other Android versions - the back would go to the settings menu 

Actual results:
- the back button returns you in the webpage previously loaded 

See video: https://youtu.be/Iy7apMTJcXI
This is pretty annoying. Flagging for triage.
tracking-fennec: --- → ?
Hi Joe, Wesly
Please help me prioritize this.
Thanks!
Flags: needinfo?(wehuang)
Flags: needinfo?(jcheng)
Keywords: regression
Priority: -- → P1
My 2 cents: Android O started shipping this week, and things like these just scream "lacks polish"...
let's decide during sprint planning
Flags: needinfo?(jcheng)
added to tomorrow's planning doc
Flags: needinfo?(wehuang)
I think :jwu is working on this. Please correct me if I'm wrong
Assignee: nobody → topwu.tw
tracking-fennec: ? → +
Looks like the behavior of HomeAsUpIndicator in Android O is changed, it doesn't pop up fragment from stack but directly leaves activity.

One simple solution is to hook HomeAsUpIndicator's click listener to call `onBackPressed()` to make sure it has same behavior of Back button.
Comment on attachment 8906442 [details]
Bug 1380266 - Keep identical click behavior between HomeAsUpIndicator and back button.

https://reviewboard.mozilla.org/r/178152/#review183450

This looks fine to me, but since I'm not familiar with code - and it's not clear to me why the previous behaviour actually functioned correctly - and so I'm not sure if this might introduce bugs on some API level. Clearing the flag, I'll rely on Nevin for his review.
Attachment #8906442 - Flags: review?(gkruglov)
Comment on attachment 8906442 [details]
Bug 1380266 - Keep identical click behavior between HomeAsUpIndicator and back button.

https://reviewboard.mozilla.org/r/178152/#review184112
Attachment #8906442 - Flags: review?(cnevinchen) → review+
Pushed by nechen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2065eef5fa19
Keep identical click behavior between HomeAsUpIndicator and back button. r=nechen
https://hg.mozilla.org/mozilla-central/rev/2065eef5fa19
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
This grafts cleanly to 56. Please nominate this for release approval so we can get it into Monday's b13.
Flags: needinfo?(topwu.tw)
Comment on attachment 8906442 [details]
Bug 1380266 - Keep identical click behavior between HomeAsUpIndicator and back button.

Approval Request Comment
[Feature/Bug causing the regression]:
This issue is caused by new platform(Android O) behavior change.

[User impact if declined]:
Non-identical HomeAsUpIndicator navigation behavior between different platform versions.

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
Not yet.

[Needs manual test from QE? If yes, steps to reproduce]: 
Yes, please check the STR in https://bugzilla.mozilla.org/show_bug.cgi?id=1380266#c0

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
This one-line change modifies the logic of menu's HomeAsUpIndicator in Android O to keep identical behavior between different platform versions.

- The change is only limited in Android O and limited in the setting page.
- The back button can always be regarded as a replacement if HomeAsUpIndicator is broken.

[String changes made/needed]:
No
Flags: needinfo?(topwu.tw)
Attachment #8906442 - Flags: approval-mozilla-beta?
Hi Ioana:

Would you help get this it verified in Nightly soon, hopefully before the next beta build? Thanks.

(In reply to Jing-wei Wu [:jwu] from comment #14)
> Comment on attachment 8906442 [details]

> [Has the fix been verified in Nightly?]:
> Not yet.
> 
> [Needs manual test from QE? If yes, steps to reproduce]: 
> Yes, please check the STR in
> https://bugzilla.mozilla.org/show_bug.cgi?id=1380266#c0

(In reply to Ryan VanderMeulen [:RyanVM] from comment #13)
> This grafts cleanly to 56. Please nominate this for release approval so we
> can get it into Monday's b13.
Flags: needinfo?(ioana.chiorean)
> Nexus 6P - Android O 
> Steps:
> 1. Go to a submenu in Settings ( Settings -> Privacy fro ex) 
> 2. Tap the back button from top  left corner 

Using the steps from the description I can not reproduce this anymore.
Flags: needinfo?(ioana.chiorean)
Comment on attachment 8906442 [details]
Bug 1380266 - Keep identical click behavior between HomeAsUpIndicator and back button.

For the fennec mobile build today (so the relbranch for 56)
Attachment #8906442 - Flags: approval-mozilla-release+
Attachment #8906442 - Flags: approval-mozilla-beta?
Attachment #8906442 - Flags: approval-mozilla-beta-
Verified as fix on the latest beta build 56.0b13.
This issue was verified on a Nexus 6P (Android 8.0)
Whiteboard: [FNC][SPT57.3][INT]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.