Add-on install warning shows confusing URI when redirecting

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
a year ago
11 months ago

People

(Reporter: ekr, Unassigned)

Tracking

({regressionwindow-wanted})

Trunk
regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox57 fix-optional)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8885920 [details]
image(1).png

STR:
1. Get a link to an XPI. E.g., https://bugzilla.mozilla.org/attachment.cgi?id=8885745
2. Put it in Slack
3. Click on the link in Slack

Expected Results:
Warning shows the domain name of bugzilla.org

Actually Results:
Warning shows the domain name of the Slack
Component: Untriaged → Notifications and Alerts
Product: Firefox → Toolkit
Component: Notifications and Alerts → Site Identity and Permission Panels
Product: Toolkit → Firefox
I assume this is not new, so it can wait for after 57. If someone could verify this with mozregression, it would be great.
status-firefox57: --- → fix-optional
Keywords: regressionwindow-wanted
I'm not 100% sure how the add-on code determines which URL to show here, it could be that the XPI is being downloaded from mozilla.slack.com...

Andy, has your team encountered this issue before?
Flags: needinfo?(amckay)

Comment 3

11 months ago
This is by design. For example, if you go to lastpass and install their extension  - the URL dialog shows lastpass.com, even though it links over to AMO.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(amckay)
Resolution: --- → WORKSFORME

Comment 4

11 months ago
Bug 1403595 comment 4 has a better explanation.

Updated

11 months ago
Duplicate of this bug: 1403595
You need to log in before you can comment on or make changes to this bug.