Duplicate "Reply All" and "Reply" buttons

RESOLVED INVALID

Status

--
minor
RESOLVED INVALID
a year ago
12 days ago

People

(Reporter: antares, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8886030 [details]
replyall.png

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/59.0.3071.109 Chrome/59.0.3071.109 Safari/537.36

Steps to reproduce:

1. Receive an email that has one or more people CC'd.



Actual results:

See screenshot - There is a button to "Reply" and another dropdown button beside it to "Reply All". When clicking on the dropdown, you are then shown the options to "Reply" or to "Reply All".


Expected results:

There should be only two buttons, one to "Reply" and one to "Reply All", and no dropdown. The current setup (having a dropdown) only makes sense if there are further options other than just "Reply" and "Reply All'. If there are no further options it should remove the dropdown altogether. This can be checked programmatically.
Component: Untriaged → Message Reader UI

Comment 1

a year ago
The second button also shows "Reply List" for a reply to a mailing list. I don't think the we want to change the existing behaviour here. We have more important bugs than this cosmetic one.
Severity: normal → minor

Comment 2

10 months ago
So the second reply is supposed to be "Reply List"? Just trying to understand what this second "Reply" represents.

Comment 3

12 days ago
I haven't seen this bug in a while. I think this is fixed in current Thunderbird.

What say the rest of the panel?
Flags: needinfo?(vseerror)
Flags: needinfo?(jorgk)
This has never impacted me.
Maybe Matt has seen reports?
Flags: needinfo?(vseerror) → needinfo?(unicorn.consulting)

Comment 5

12 days ago
This bug is actually invalid since it works as designed. The smart reply button shows "Reply List", "Reply All" and "Reply" depending on the context.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 days ago
Flags: needinfo?(jorgk)
Resolution: --- → INVALID

Comment 6

12 days ago
Perhaps I should file a bug to have the smart reply on the main toolbar as well. I do not get the benefit of so many of these enhancements because I simply do not use the message toolbar (compact header). But the only reports I have seen about the smart reply date to the time of implementation and were basically users not understanding the interface changes.
Flags: needinfo?(unicorn.consulting)
You need to log in before you can comment on or make changes to this bug.