Click on web link opens predefined Home page instead of link target

RESOLVED DUPLICATE of bug 1379369

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 1379369
15 days ago
15 days ago

People

(Reporter: Rainer Bielefeld, Unassigned)

Tracking

SeaMonkey 2.53 Branch
Unspecified
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [easyconfirm])

Attachments

(1 attachment)

(Reporter)

Description

15 days ago
Steps how to reproduce with unzipped installer of  official en-US SeaMonkey 2.53a1 (NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0 Build 20170711003903  (Default Classic Theme) on German WIN7 64bit:

0. Open above mentioned SeaMonkey after having unzipped installer.exe by
   double click (in WIN Files Explorer) on “seamonkey.dexe” in folder “core”
   → via 'Tools → Switch Profile' create and open new User Profile
1. Open attached testdocument1.pdf from (WIN Files Explorer) in AR10
2. Click on string “seamonkey blog” with link behind it
   Expected: <https://unofficialseamonkeynews.wordpress.com/> opens 
             in Browser
   Actual: <https://www.seamonkey-project.org/start/> (which ist home page 
           for new user profile when opene first time) opens.
4. Open other page or picture like
   <https://de.wikipedia.org/wiki/Haselmaus#/media/File:Haselmaus.JPG>
   Drag and Drop that link form Location Bar to “Home” link in 
   Bookmarks Toolbar
5. Click on string “seamonkey blog” with link behind it
   Expected: <https://unofficialseamonkeynews.wordpress.com/> opens 
             in Browser
   Actual: dormouse picture opens.

a) Was still ok with unzipped installer of official SeaMonkey 2.53a1 
   (NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0 
   Build 20170706013410  (Default Classic Theme) on German WIN7 64bit
b) Same effect from other documents not opened in SeaMonkey, for example
   Link in “Help – About” from Filezilla or Audacity 2.0.1
(Reporter)

Comment 1

15 days ago
c) no obvious DUP found in <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=DUPs1380566&sharer_id=41036>
(Reporter)

Comment 2

15 days ago
Created attachment 8886032 [details]
Document for tests

For a test please proceed as per original report.
(Reporter)

Comment 3

15 days ago
d) In some cases (may be dependent on Browser and Tabbed Browsing preferences) not the 
   Home Page, but "Untitled" might be opened.
Works for me. This is likely fallout from bug 1379369.

The bug affects all urls passed from the outside to SeaMonkey. Let me know if you want a later test build. Still need some time to fix it properly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1379369
You need to log in before you can comment on or make changes to this bug.