Limited domain permission request looks scarier than <all_urls> request

REOPENED
Unassigned

Status

P3
normal
REOPENED
2 years ago
20 days ago

People

(Reporter: ke5trel, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8886096 [details]
permissions-all-vs-limited.png

Asking permission for <all_urls>:

* "Access your data for all websites"

Asking permission for a small number of domains:

* "Access your data for sites in the youtube.com domain"
* "Access your data for sites in the soundcloud.com domain"
* "Access your data for sites in the vimeo.com domain"
* "Access your data in 8 other domains"

The limited permission request is a bigger list, making it look like it is asking for more permissions than the <all_urls> request which is counter-intuitive. It is also hard to parse and quickly determine how many domains in total are being requested.

Possible alternative:

* "Access your data for ALL websites"

* "Access your data for 11 domains including youtube.com, soundcloud.com and vimeo.com"
(Reporter)

Updated

2 years ago
Blocks: 1308292
Whiteboard: [permissions][triage]
Scott, what do you think
Flags: needinfo?(sdevaney)
Whiteboard: [permissions][triage] → [permissions]

Comment 2

2 years ago
Not sure if this is coincidence or not, but I just got out of a conversation with UX about permissions copy. It tested scary in recent user tests. We may explore softening it places or clarifying in others. So let's leave as-is for now, since broader changes may come. Thanks.
Flags: needinfo?(sdevaney)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Updated

8 months ago
Product: Toolkit → WebExtensions
(Reporter)

Comment 3

27 days ago

Reopening for post 57 permissions improvement meta bug (Bug 1401643).

Blocks: 1401643
No longer blocks: 1308292
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
Whiteboard: [permissions]
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.