Closed Bug 1380604 Opened 4 years ago Closed 4 years ago

Race in FetchConsumer

Categories

(Core :: DOM: Service Workers, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: catalinb, Assigned: catalinb)

Details

(Keywords: crash)

Attachments

(1 file)

I think there's a race between running BeginConsumeBodyMainThread on MT and ReleaseObject on the worker thread when the worker is shutting down. This causes this crash (with the patches from 1344751):
https://treeherder.mozilla.org/logviewer.html#?job_id=113828957&repo=try&lineNumber=1891

One possible cause is http://searchfox.org/mozilla-central/source/dom/fetch/FetchConsumer.cpp#689 failing to dispatch when called from Notify, since the worker is already in Terminating state.
Component: DOM → DOM: Service Workers
Attachment #8886114 - Flags: review?(amarchesini)
Attachment #8886114 - Flags: review?(amarchesini) → review+
Pushed by catalin.badea392@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/530b1eb0a548
Use Killing when dispatching the sync runnable in FetchBodyConsumer::ShutDownMainThreadConsuming. r=baku
https://hg.mozilla.org/mozilla-central/rev/530b1eb0a548
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Duplicate of this bug: 1381748
Assignee: nobody → catalin.badea392
Keywords: crash
You need to log in before you can comment on or make changes to this bug.