Closed Bug 1380630 Opened 2 years ago Closed 2 years ago

4.89 - 17.01% tp5o Main_RSS / tp5o_webext Main_RSS / tp5o_webext Modified Page List Bytes (windows7-32) regression on push 86a96e12230de44c2fd3b249d8f2d2912435eca4 (Wed Jul 12 2017)

Categories

(Core :: Graphics: WebRender, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: igoldan, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=86a96e12230de44c2fd3b249d8f2d2912435eca4

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 17%  tp5o_webext Main_RSS windows7-32 opt e10s     121,062,964.30 -> 141,658,800.40
 17%  tp5o Main_RSS windows7-32 pgo e10s            121,418,158.81 -> 141,902,600.83
 14%  tp5o Main_RSS windows7-32 opt e10s            123,722,191.45 -> 141,306,053.42
  5%  tp5o_webext Modified Page List Bytes windows7-32 opt e10s62,754,192.93 -> 65,820,499.75

Improvements:

 28%  tp5o responsiveness windows7-32 opt e10s     6.48 -> 4.66
 22%  tp5o_webext responsiveness windows7-32 opt e10s5.99 -> 4.67


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=7882

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
See Also: → 1380593
Component: Untriaged → Graphics: WebRender
Product: Firefox → Core
:lsalzman Please look over these Talos regressions too. Could you estimate a fix time for them?
Flags: needinfo?(lsalzman)
Just so we're clear (since I don't think it always is), these regressions appear to be memory regressions. I suspect this is detecting the same thing as bug 1380593.
The increase in memory usage is a consequence of moving to using DirectWrite for fonts on the Windows 7 test machines, which do not have the Platform Update with Direct2D 1.1 installed. This does not affect any later versions of Windows we release on.

Since the Windows 7 test machines did not have the Platform Update installed, and consequently no Direct2D 1.1, a bug prevented us from enabling DirectWrite there.

Bug 1376026 changed this behavior, as we want to transition towards using DirectWrite for text on all Windows platforms, rather thatn the older GDI fonts system that was only in use for an increasingly vanishing subset of our Windows users.

As such, we acknowledge and accept this memory usage regression as the cost of using DirectWrite, which we believe to be beneficial enough overall to outweigh the regression.
Flags: needinfo?(lsalzman)
thanks!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.