Closed Bug 1380645 Opened 2 years ago Closed 2 years ago

Update webrender to b83c200c657f6b6fb17d09f329ba77803420b46a

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1379604 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
Blocks: 1382098
WR @ 8fd634882111415a65da67e947f26eb170234f2f

https://treeherder.mozilla.org/#/jobs?repo=try&revision=136279f480a9763e5728931b4cecf9a6850c27cf
https://treeherder.mozilla.org/#/jobs?repo=try&revision=b435efae5f8ef50f513bde9f37896ed42d77c59f

Bustage, looks like a bindings problem. Regression range:

*   8fd6348 Auto merge of #1504 - glennw:lines, r=kvark
|\
| * 1fd1eaa Basic implementation of line decoration display items.
| * bb8f891 Add LineDisplayItem to Wrench, add reftest
| * 88ac352 add LineDisplayItem
* dc746ed Auto merge of #1445 - kvark:namespace, r=glennw
* 6a2662c Cleaning resources on RenderApi::drop
The problem is that the FontKey struct in WR has been updated to include IdNamespace [1]. Both FontKey and IdNamespace have type aliases to deal with them being tuples with unnamed fields [2], but since FontKey contains IdNamespace and not WrIdNamespace, cbindgen doesn't use the alias in this case and generates a definition for IdNamespace [3] which doesn't compile.

Ryan, is there a good way to fix this (either in cbindgen, or in our bindings file)?

[1] https://hg.mozilla.org/try/rev/97063d8add4d5b22074727489f33c3d3011b297b#l26.26
[2] http://searchfox.org/mozilla-central/rev/3a3af33f513071ea829debdfbc628caebcdf6996/gfx/webrender_bindings/src/bindings.rs#44,51
[3] https://hg.mozilla.org/try/rev/1a09edf45c1589b7a5224148c3aa69292e4c6cdb#l1.12
Flags: needinfo?(rhunt)
I'm going to land the update to b83c200c657f6b6fb17d09f329ba77803420b46a (last green change) since it's been over a week since the last update. I'll move the binding discussion over to the new bug I file for the next update.
Assignee: nobody → bugmail
Flags: needinfo?(rhunt)
Summary: Future webrender update bug → Update webrender to b83c200c657f6b6fb17d09f329ba77803420b46a
Comment on attachment 8888768 [details]
Bug 1380645 - Update webrender to cset b83c200c657f6b6fb17d09f329ba77803420b46a.

https://reviewboard.mozilla.org/r/159820/#review165144
Attachment #8888768 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2359ba2d006
Update webrender to cset b83c200c657f6b6fb17d09f329ba77803420b46a. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/f2359ba2d006
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.