Crash in firefox@0x1c69c

RESOLVED WONTFIX

Status

()

Firefox
Untriaged
P3
critical
RESOLVED WONTFIX
a year ago
9 months ago

People

(Reporter: lionel, Unassigned)

Tracking

57 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox57 wontfix, firefox58 affected)

Details

(crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-89e5f6a5-3af9-4d81-be4f-3c8001170713.
=============================================================

Hello,
For some days, firefox crashes on some particular webpages : it has begun with the 53 release, and now with the 54.
I am under the up-to-date rolling release archlinux.

Firefox crashes always on the same pages.
Sometimes that could be pages with too much ads, and I don't care too much about the crash.

But now, I cannot acces to my Yahoo-email login page :
There is no problem to access to the first step to write my email address, and then the next page is about password : I cannot write my password because the tab is not responding and crashes.

This beahavior is critical because access of emails are necessary (for now, i use another browser than FF)


-----
Some messages :

[Parent 11982] WARNING: pipe error (67): Connexion ré-initialisée par le correspondant: file /build/firefox/src/mozilla-unified/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 346

###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0082,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

-----

I tried to come back to the 53 version, including :
libevent-2.0.22-4 + firefox-53.0.2-1 + firefox-i18n-fr-53.0.2-1 packages 

That was the same message :

[Parent 11982] WARNING: pipe error (67): Connexion ré-initialisée par le correspondant: file /build/firefox/src/mozilla-unified/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 346

###!!! [Parent][MessageChannel] Error: (msgtype=0x2C0082,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv


-----

I also tried to go back to 52 version, but at that time I faced problems with some libraries, and I should be back to 54.


If you want to do some tests, do not hesitate,
Thank you for your help.
(Reporter)

Comment 1

11 months ago
Hi,
Under safe-mode, there is no crash, I can normaly enter my password and get into my Yahoo mail box.
I've removed all my modules, clean the cache, but the bug remain (not only with Yahoo but also other les important sites)...

Note :
In my /etc/hosts/ (I am under linux), I've written : 0.0.0.0 google-analytics.com
I've read Firefox is still using Google analytics even if users haven't confirmed this choice...

I hope Firefox is not going in a wrong way and sending Yahoo passwords to Google... Have you checked ? Thanks

Updated

11 months ago
Component: Activity Streams: General → Activity Streams: Newtab

Comment 2

10 months ago
Try Ctrl + Shift + K on the yahoo login page and see if you can see any errors in the console.
(Reporter)

Comment 3

10 months ago
Thanks for the try,
I give up Yahoo mail,

But the problem occurs also with other websites. For instance (but there are severals), www.lemonde.fr (French media), and www.pagesjaunes.fr. For this last website, there is no crash when I open the page, and no crash when I look for a phone number. The crash occurs only when I click on "afficher le numéro".

My hosts file send back analitics.google.com to 0.0.0.0 and there is no way to ask me for changing it.

This bug still go on 55.0.1 release...

Comment 4

10 months ago
I use firefox latest version on Ubuntu but I'm unable to reproduce this bug. I also use adgaurd DNS, which blocks trackers and ads at router level and never had any issue. I would suggest you to open a private window on firefox and try to see if the problem still exists on private browsing mode, if it's not there, the problem might be some of your extensions. 
Regards
(Reporter)

Comment 5

10 months ago
Thank you hgs,
The problem still exists in private browsing.
I've also tried different profiles, but it still crashes whatever the profile I use, even after deleting cache, history and removing modules.

But if I am in safe mode, there isn't any crash.

Where can I find the FF console records ? (after Ctrl-shift-K)

Thanks,
lionel

Comment 6

10 months ago
Since it's all right in Safe Mode, I would recommend you to follow this troubleshooting guide : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems?redirectlocale=en-US&redirectslug=Troubleshooting+extensions+and+themes#w_the-problem-does-not-occur-in-safe-mode 

If nothing works, visit about:config on your browser and click "Refresh Firefox" that will remove all extensions and restore the settings.

Regards.
(Reporter)

Updated

10 months ago
Version: 54 Branch → 55 Branch
(Reporter)

Comment 7

10 months ago
Thank you again for your help, but it still doesn't work.

I've removed Firefox, and then installed the 55.0.1 branch, and now the 55.0.3

I've turned off hardware acceleration, 
I was still on default theme, 
I've disabled all extensions, even plugins video codec OpenH264 and Shockwave Flash, 
and restarted. Nothing, the problem still occurred.

I've refreshed Firefox (from about:support instead of about:config)

It works normaly under safe mode, but folder crashes under normal mode (now, it is the folder instead of the whole Firefox).

Some sites with problems :
www.lemonde.fr
www.pagesjaunes.fr
www.rustica.fr
www.streetpress.com
and so on...

The problem often occurs when I click on any article. The new page display, but not entirely. I need 1 or 2 or 3 minutes before the webpage freezes and the folder crashes.

Regards
(Reporter)

Comment 8

10 months ago
Please, do you have any idea to solve it ?
Thanks

Comment 10

9 months ago
I tried all I could to reproduce this error but I was not successful. I don't know what's wrong :(
(Reporter)

Comment 11

9 months ago
Ok, I've installed the Firefox Nightly 57 and the bug still occurs.
I change the flag.
(Reporter)

Updated

9 months ago
Version: 55 Branch → 57 Branch

Updated

9 months ago
status-firefox57: --- → wontfix
status-firefox58: --- → affected
Priority: -- → P3
(Reporter)

Comment 12

9 months ago
New information :
I use iptables as firewall.
When I disable iptables, the bug doesn't occur.
I thing this behavior is dangerous because this is a lack of security...

Here is my IPtables :

num  target     prot opt source               destination         
1    ACCEPT     all  --  anywhere             anywhere            
2    DROP       tcp  --  anywhere             anywhere             tcp flags:FIN,PSH,URG/FIN,PSH,URG
3    DROP       tcp  --  anywhere             anywhere             tcp flags:FIN,SYN,RST,PSH,ACK,URG/FIN,SYN,RST,PSH,ACK,URG
4    DROP       tcp  --  anywhere             anywhere             tcp flags:FIN,SYN,RST,PSH,ACK,URG/NONE
5    DROP       tcp  --  anywhere             anywhere             tcp flags:SYN,RST/SYN,RST
6    DROP       all  --  anywhere             anywhere             PKTTYPE = broadcast
7    ACCEPT     all  --  anywhere             anywhere             state ESTABLISHED
8    LOG        all  --  anywhere             anywhere             LOG level warning

Chain FORWARD (policy DROP)
num  target     prot opt source               destination         
1    LOG        all  --  anywhere             anywhere             LOG level warning

Chain OUTPUT (policy DROP)
num  target     prot opt source               destination         
1    ACCEPT     all  --  anywhere             anywhere             ! state INVALID

Updated

9 months ago
Component: Activity Streams: Newtab → Untriaged
Karl, could you please lend a bit of help on this issue. I'm not sure how to debug this or advance it further.
Flags: needinfo?(karlt)
WebGL has been used in most of the reports in comment 9 and r300_dri.so appears in a couple.
I'd try disabling WebGL, even though that seems unrelated to comment 12.
Flags: needinfo?(karlt)
(Reporter)

Comment 15

9 months ago
Thank you, that was it : webGL should be disabled
In about:config , webgl.disabled should be set from "false" to "true"

For French readers, some good ideas at : https://vive-gnulinux.fr.cr/securiser-firefox/#comment-219

Thanks again, the bug is closed 
(Reporter)

Updated

9 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.