bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

mach build fails: "Unable to find android sdk's lint jar"

RESOLVED DUPLICATE of bug 1344244

Status

()

Firefox for Android
Build Config & IDE Support
RESOLVED DUPLICATE of bug 1344244
a year ago
a year ago

People

(Reporter: mcomella, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 8886270 [details]
Failure output

I had an existing install of m-c that I'm trying to revive. I ran `mach bootstrap`, but there were a lot of errors (I pieced it together as much as possible) but now `mach build` still fails. Here's the key error line:

 0:07.63 DEBUG: configure: error: Unable to find android sdk's lint jar. This probably means that you need to update android.m4 to find the latest version of lint-*.jar and all its dependencies. (looked for /Users/mcomella/.mozbuild/android-sdk-macosx/tools/lib/lint-25.3.1.jar and /Users/mcomella/.mozbuild/android-sdk-macosx/tools/lib/lint.jar)

I'm guessing I downloaded a new version when I ran `mach bootstrap`. If things haven't changed, the Android SDK doesn't make it easy to get `x.x.x` releases (as opposed to `x.x`) so I think we should just bump the dependency to the latest version. Though, I wonder about the time it'd take to update the build machines with the latest dependencies too and get everyone up to the latest version...

Nick, any ideas? Or perhaps there's someone else who'd be more appropriate to ask at this point?
Flags: needinfo?(nalexander)
Comment on attachment 8886275 [details] [diff] [review]
Patch-ish

I can't remember how to post a patch but this change works locally.
Attachment #8886275 - Attachment description: Patch → Patch-ish
Attachment #8886275 - Attachment is patch: true
This will be addressed by the part 1 patch that has r+ on Bug 1344244.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(nalexander)
Resolution: --- → DUPLICATE
Duplicate of bug: 1344244
You need to log in before you can comment on or make changes to this bug.