Isolated CSS Custom properties not cascading when unset when layout.css.servo.enabled is on

RESOLVED DUPLICATE of bug 1380224

Status

()

RESOLVED DUPLICATE of bug 1380224
a year ago
a year ago

People

(Reporter: dsmith, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8886318 [details]
customPropertyCascade.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170713030205

Steps to reproduce:

When an element deeper in the dom is affected by a change in a custom property, and that property's value is changed, it is not cascaded down to the lower elements when Stylo (layout.css.servo.enabled) is on, and there are no immediate effects on the main element.


Actual results:

The first attachment shows the basic testcase.  If the layout.css.servo.enabled pref is true, then the hidden content will not be shown when the button is pressed.  If it is false, then it will be.

This same effect can be seen with other properties, such as setting border or background colors.

The second attachment (to be added) shows a variation where, if there is another custom property that affects the top element itself, the hidden content will be shown even when using Stylo for CSS.


Expected results:

Changing the custom property should always cascade down to child elements.
(Reporter)

Comment 1

a year ago
Created attachment 8886320 [details]
customPropertyCascade2.html

Second test case, showing it working when another property is changed on the top element.
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Thanks for the bug report.  This is bug 1380224.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380224
You need to log in before you can comment on or make changes to this bug.