Regxpcom.exe crashes with the error: "NMAKE : fatal error U1077: 'regxpcom.exe' : return code '0xc0000005'", making the trunk build fail.

RESOLVED FIXED

Status

()

Core
XPCOM
--
critical
RESOLVED FIXED
16 years ago
a year ago

People

(Reporter: John "AntiTuX" Dee, Assigned: dougt)

Tracking

({crash, smoketest})

Trunk
x86
Windows NT
crash, smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
regxpcom.exe is crashing with the following error (and dialog). I was unable to
get the screenshot of the dialog box, but here's what I have from the log.

*SNIP*
NMAKE : fatal error U1077: 'regxpcom.exe' : return code '0xc0000005'
Stop.
NMAKE : fatal error U1077: 'C:\PROGRA~1\MICROS~1\VC98\BIN\NMAKE.EXE' :
return code '0x2'
Stop.
NMAKE : fatal error U1077: 'C:\PROGRA~1\MICROS~1\VC98\BIN\NMAKE.EXE' :
return code '0x2'
Stop.

I am unable to get a mozilla trunk verification build out because of this.

Updated

16 years ago
Keywords: crash

Updated

16 years ago
Keywords: smoketest

Comment 1

16 years ago
confirming, i've been seeing this the last couple of days.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Are we still supporting nmake ?
(Assignee)

Comment 3

16 years ago
Created attachment 79737 [details] [diff] [review]
Fixes problem

Don't hold references passed xpcom shutdown
(Assignee)

Comment 4

16 years ago
Created attachment 79741 [details] [diff] [review]
even better patch

this has been checked into the trunk...
Attachment #79737 - Attachment is obsolete: true

Comment 5

16 years ago
note that this affects all platforms that use regxpcom to pre-generate a
component registry (unix, windows), regardless of build system.
(Assignee)

Comment 6

16 years ago
also missed 138090 which is not important

Comment 7

16 years ago
Comment on attachment 79741 [details] [diff] [review]
even better patch

this should probably go in for rc1
Attachment #79741 - Flags: approval+
(Assignee)

Comment 8

16 years ago
fixed on trunk....  making critical since I want this to land for rc1.
Severity: blocker → critical
(Assignee)

Comment 9

16 years ago
Checking in regxpcom.cpp;
/cvsroot/mozilla/xpcom/tools/registry/regxpcom.cpp,v  <--  regxpcom.cpp
new revision: 1.18.16.3; previous revision: 1.18.16.2
done


checked into branch.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 10

16 years ago
adding fixed1.0.0 keyword (branch resolution). This bug has comments saying it
was fixed on the 1.0 branch and a bonsai checkin comment that agrees. To verify
the bug has been fixed on the 1.0 branch please replace the fixed1.0.0 keyword
with verified1.0.0.
Keywords: fixed1.0.0

Updated

10 years ago
Component: XPCOM Registry → XPCOM
QA Contact: doug.turner → xpcom
Comment hidden (offtopic)
You need to log in before you can comment on or make changes to this bug.