Closed Bug 1380855 Opened 3 years ago Closed 2 years ago

Intermittent browser/components/extensions/test/browser/browser_ext_devtools_panel.js | Test timed out -

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set

Tracking

(firefox58 wontfix, firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox58 --- wontfix
firefox59 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: rpl)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Specifically, the timeout was in the newly-added subtest from bug 1425224. Can you please look, Luca?
Flags: needinfo?(lgreco)
Attachment #8940678 - Flags: review?(mixedpuppy)
The attached patch applies the following change to the devtools panel test file:

- it register a custom blank tool to the developer tools, so that we can avoid to load the webconsole panel
  (which is not used by any of the tests from this file and it takes a good amount of time to load, and to unload
  and free all the allocated resources)

- change the the last test file to not use `extension.onMessage`, because a listener subscribed to it is not removed
  as fast as the listeners added by extension.awaitMessage and so it seems to keep some of the objects referenced
  for more time and it is detected as leak by the "shutdown leak checks" (but apparently only if the last test
  runs alone)

From what I saw by reproducing it locally (I've been able to reproduce it locally on linux64-debug using --verify mochitest cli option), the timeouts are related to a GC pause, which has generated two kind of failures:

- the webconsole fails to load (because it timeouts while loading when the GC pause happens during the webconsole loading) and a "panel is undefined" exception is logged in the console (I think that this also unveiled an existent issue in the webconsole loading, I'm going to open it as a separate bugzilla issue)

- timeouts while testing that panel is created and works as inspected when using a valid url, and looking at the failure screenshots the webconsole is unexpectedly opened as a split console when the test panel is selected (which I guess is happening because the panel is selected while the webconsole panel is still loading slowly due to the GC pause) 

I've pushed this change to try to run TV (the test runnning with --verify) on OSX a bunch of times and check if I can still reproduce the intermittent failure on the build infrastructure (it has never failed, at least not yet):

- https://treeherder.mozilla.org/#/jobs?repo=try&revision=189c4c4f4961
Flags: needinfo?(lgreco)
Comment on attachment 8940678 [details]
Bug 1380855 - Fix intermittency and speed up devtools panel webextension test.

https://reviewboard.mozilla.org/r/210934/#review216956
Attachment #8940678 - Flags: review?(mixedpuppy) → review+
Assignee: nobody → lgreco
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/53dbfc8bbc85
Fix intermittency and speed up devtools panel webextension test. r=mixedpuppy
https://hg.mozilla.org/mozilla-central/rev/53dbfc8bbc85
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Flags: qe-verify-
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.