Closed Bug 1380866 Opened 5 years ago Closed 5 years ago

[vi] Search engine setup for Firefox Mobile for Vietnamese.

Categories

(Mozilla Localizations :: vi / Vietnamese, enhancement)

enhancement
Not set
normal

Tracking

(firefox57 fixed)

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: delphine, Assigned: delphine)

References

()

Details

(Keywords: productization)

Attachments

(3 files)

Seems like we already have a list for mobile on central for this: https://hg.mozilla.org/mozilla-central/file/tip/mobile/locales/search/list.json#l670

I'd like to have community confirm that they are fine with these though, since I'm probably gonna have to update some files anyways.

Here is the typical text we usually send out for setting up search engines:

We want to ship Firefox Mobile with a good list of search engines for Vietnamese. 

We're going to work towards this in three phases. First, the localization team and the l10n drivers will look at the market for the language and come up with a good set of search providers. Vietnamese team, we'll need your input on this, the guidelines for making recommendations are on <https://wiki.mozilla.org/L10n:Mobile/Productization>. 

For en-US, we currently use this set, to which we can fall back in the case of lacking localized alternatives:

> Google, Yahoo, Bing, Amazon, Twitter, Wikipedia

We may also want to go with just a subset of the en-US engines, if that's more appropriate for the local market.

Once we decide to use a particular search engine (and we test it on a mobile device), l10n drivers will contact the owner and ask for permission, and for specifics like proper search flags. We'll likely need your help to at least get the contact information.

For search engines that we already ship with on desktop and that you would like to include in mobile as well, the permission is not needed.  Consider using a mobile version of the engine if one is available. For Android we'll want a specific 96x96px image, with colored background and rounder corners (6px radius).

Once we have a specification on what the search engines for Vietnamese should look like, Delphine and the localization team will work on the implementation. Delphine will create and attach patches for the desired changes and get them reviewed. After a successful review, Delphine will land them. Vietnamese team, if you're interested, you could create the patches, too. You'd ask Delphine for review on those before landing. 

Please don't commit any modifications in browser/searchplugins to the hg repository without a patch reviewed by delphine, flod, Axel or someone else appointed by the l10n drivers. The data here is sensitive to users and our search partners, thus the extra care here.

The Vietnamese team and Delphine will be driving this bug to completion.
(Confirming that some search engines are missing anyways from the existing list, so I will need to update this no matter what ;) )
I noticed Cốc Cốc (https://coccoc.com/search) is quite popular in Vietnam. Otherwise, I did also notice that most people use Google otherwise. Although, since I live in France (I only occasionally go to Vietnam), I'm not the best person to refer to :)
I did also notice some young people use Zing instead of Facebook, so it might be a good replacement for Twitter or Facebook.

Alexa seems to confirm what I said about Coc Coc btw: http://www.alexa.com/topsites/countries/VN
adding carnold, who is working a deal with CocCoc.  

Also, we historically Facebook has been avoided as it requires the user to login rather than just perform a search.
Flags: needinfo?(carnold)
Confirmed on Facebook: websites that require a login/account to search are a no-go.

There's also an ongoing discussion about CocCoc in bug 1380846 (these two bugs were filed together just by pure coincidence).
It is fine to add Cocccoc to Fennec search list.
Flags: needinfo?(carnold)
Coc Coc is not good choice beacause its speed is slow and their policies that does not good for internet health. It is based on Chromium, I don't suppose it's necessary to add any more search engine. Google search is enough
We work with companies that have Chromium browsers.  That's not a concern for us.  This collaboration isn't about their browser but their search search engine which is accessible here: http://coccoc.com/search#! 

Could you let us know what policy they have that concerns you?
We haven't heard back from our localizers on comment 8. 

I'd like to move forwards with this. Please let us know if you have any concerns, otherwise I'll proceed next week to add:
Google, Yahoo, Bing, Amazon, Twitter, Wikipedia and Cocccoc 

Thanks everyone!
We need some help getting the icon for mobile.

@Christopher
On Fennec we use a 96px PNG icon, with colored background, and rounded corners (6px radius). Do you think we can help with that? We also need to know if we can use the same parameters as desktop

Maybe it's worth splitting out that searchplugin in a different bug.
Flags: needinfo?(carnold)
(In reply to Francesco Lodolo [:flod] from comment #10)
> We need some help getting the icon for mobile.
> 
> @Christopher
> On Fennec we use a 96px PNG icon, with colored background, and rounded
> corners (6px radius). Do you think we can help with that? We also need to
> know if we can use the same parameters as desktop

For reference
https://l10n.mozilla-community.org/~flod/p12n/collage/?product=mobile&channel=trunk
(In reply to Delphine Lebédel [:delphine - use Need Info] from comment #9)
> We haven't heard back from our localizers on comment 8. 
> 
> I'd like to move forwards with this. Please let us know if you have any
> concerns, otherwise I'll proceed next week to add:
> Google, Yahoo, Bing, Amazon, Twitter, Wikipedia and Cocccoc 
> 
> Thanks everyone!

I'll check with our contracted partners that we're okay to send traffic from Vietnam.  I am not certain Amazon offers a localized service there.
Flags: needinfo?(carnold)
(In reply to Francesco Lodolo [:flod] from comment #11)
> (In reply to Francesco Lodolo [:flod] from comment #10)
> > We need some help getting the icon for mobile.
> > 
> > @Christopher
> > On Fennec we use a 96px PNG icon, with colored background, and rounded
> > corners (6px radius). Do you think we can help with that? We also need to
> > know if we can use the same parameters as desktop
> 
> For reference
> https://l10n.mozilla-community.org/~flod/p12n/collage/
> ?product=mobile&channel=trunk

I'll ask them for new logo design and get back as soon as they provide it.
Hello Delphine, Please feel free to proceed with Google, Twitter, Wikipedia, Duckduckgo and Cocccoc.
Attached image coccoc-96x96.png
New logo for Fennec search provider Coccoc.
(In reply to Francesco Lodolo [:flod] from comment #11)
> (In reply to Francesco Lodolo [:flod] from comment #10)
> > We need some help getting the icon for mobile.
> > 
> > @Christopher
> > On Fennec we use a 96px PNG icon, with colored background, and rounded
> > corners (6px radius). Do you think we can help with that? We also need to
> > know if we can use the same parameters as desktop
> 
> For reference
> https://l10n.mozilla-community.org/~flod/p12n/collage/
> ?product=mobile&channel=trunk

Thank Francesco, I've attached the mobile logo.  I'll ask Mike about the search parameter.
Flags: needinfo?(mozilla)
Attached image coccoc-grey-96x96-4.png
Second version of logo on gray background.
(In reply to Francesco Lodolo [:flod] from comment #11)
> (In reply to Francesco Lodolo [:flod] from comment #10)
> > We need some help getting the icon for mobile.
> > 
> > @Christopher
> > On Fennec we use a 96px PNG icon, with colored background, and rounded
> > corners (6px radius). Do you think we can help with that? We also need to
> > know if we can use the same parameters as desktop
> 
> For reference
> https://l10n.mozilla-community.org/~flod/p12n/collage/
> ?product=mobile&channel=trunk

Hi Francesco, could we go with the second logo?  It looks much more dynamic than the green one.
(In reply to Christopher Arnold from comment #18)
> Hi Francesco, could we go with the second logo?  It looks much more dynamic
> than the green one.

Definitely no issue on my side, as long as it's colored, we're fine.
Let's use ffmobile for the search param (modeling the browser search plugin)
Flags: needinfo?(mozilla)
Hey everyone - thanks for providing everything we need to move forwards with this. I'm currently traveling with bad connection :) I can take care of this later next week when I come back!
Flags: needinfo?(lebedel.delphine)
Delphine:

Is this still on your radar or do you want me to pull something together?
Hey! still on my radar, sorry for the lag, it's been hectic around here :) Gonna get to this today
(In reply to Christopher Arnold from comment #14)
> Hello Delphine, Please feel free to proceed with Google, Twitter, Wikipedia,
> Duckduckgo and Cocccoc.
I think we need to include Yahoo and Bing there by default as well (as per partnership requirements).

For the .xml, if I understand correctly, I can copy the existing browser one and just use ffmobile for the search param, correct?

I'm working on getting the icon ready now, I'm new to doing the icon part so this might take a bit of time :)
(In reply to Delphine Lebédel [:delphine - use Need Info] from comment #24)
> I'm working on getting the icon ready now, I'm new to doing the icon part so
> this might take a bit of time :)

It should be documented, but it might be incomplete.

1) Get this icon
https://bugzilla.mozilla.org/attachment.cgi?id=8894866

2) Minimize it (that sheds half the size)
https://tinypng.com/

3) Encode it, use the "Browser view" in the XML file
http://freeonlinetools24.com/base64-image
(In reply to Delphine Lebédel [:delphine - use Need Info] from comment #24)
> (In reply to Christopher Arnold from comment #14)
> > Hello Delphine, Please feel free to proceed with Google, Twitter, Wikipedia,
> > Duckduckgo and Cocccoc.
> I think we need to include Yahoo and Bing there by default as well (as per
> partnership requirements).
> 
> For the .xml, if I understand correctly, I can copy the existing browser one
> and just use ffmobile for the search param, correct?
> 
> I'm working on getting the icon ready now, I'm new to doing the icon part so
> this might take a bit of time :)

Hi Delphine, I checked with the strategic partnerships team.  They do not recommend inclusion of Yahoo! and Bing in this case.
Awesome thanks for the heads-up. Working on a patch now
Comment on attachment 8900856 [details]
Bug 1380866 - vi Search engine setup for Firefox Mobile for Vietnamese,

https://reviewboard.mozilla.org/r/172298/#review177576
Attachment #8900856 - Flags: review?(francesco.lodolo) → review+
Pushed by francesco.lodolo@mozillaitalia.org:
https://hg.mozilla.org/integration/autoland/rev/834bbf6193e9
vi Search engine setup for Firefox Mobile for Vietnamese, r=flod
https://hg.mozilla.org/mozilla-central/rev/834bbf6193e9
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Duplicate of this bug: 522010
You need to log in before you can comment on or make changes to this bug.