Closed Bug 1380898 Opened 4 years ago Closed 4 years ago

Account Settings Signature text box needs a minimum vertical height

Categories

(Thunderbird :: Account Manager, defect)

52 Branch
defect
Not set
minor

Tracking

(thunderbird_esr5255+ fixed, thunderbird55 wontfix, thunderbird56 fixed)

RESOLVED FIXED
Thunderbird 56.0
Tracking Status
thunderbird_esr52 55+ fixed
thunderbird55 --- wontfix
thunderbird56 --- fixed

People

(Reporter: Pascal, Assigned: Paenglab)

Details

Attachments

(2 files, 1 obsolete file)

The Account Settings window automatically gets a vertical scrollbar as needed for short monitors.  Unfortunately, it first reduces the height of the Signature text box to the point that it is extremely difficult to use.

It would be nice if the Signature text box had a minimum height of at least two lines.

This problem is easy to reproduce on any monitor by dragging up the bottom of the Account Settings window.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch Bug1380898.patch (obsolete) — Splinter Review
This gives the signatureBox a minimal height which can't be undercut.

I added it directly to the XUL instead to the CSS files because this is more a flex change than a style change. I set 80px because when we have already a signature in the box which overflows we have scrollbars and make it tinier could lead us to see only the scrollbars.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8886766 - Flags: review?(jorgk)
Ah, forgot: Sorry, the patch has a lot of whitespace changes. We should really cleanup mailnews like we've done for mail. What do you think?
I'm having a bad time with this bug. I'm editing
C:\mozilla-source\comm-central\obj-x86_64-pc-mingw32\dist\bin\chrome\messenger\content\messenger\am-main.xul
to try various sizes but the changes don't take effect. In the end, I had to do a full build which takes 4 minutes.

I think 80px is much too high. I think 50px is OK, at that size you can fit two lines and the scroll bars are always visible.
How about 60px?
This is about a min-size, right? Not about a "best" size. 50px fits 2.5 lines and has a scrollbar. 60px fits tree lines which I think isn't necessary for minimum height.

Anyway, you're the UX boss, so if they are compelling reasons for 60px, I won't argue.
Attached patch Bug1380898.patchSplinter Review
Okay, with min-height: 50px.
Attachment #8886766 - Attachment is obsolete: true
Attachment #8886766 - Flags: review?(jorgk)
Attachment #8886820 - Flags: review?(jorgk)
Comment on attachment 8886820 [details] [diff] [review]
Bug1380898.patch

Sure ;-)
Attachment #8886820 - Flags: review?(jorgk) → review+
Thanks
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/4e29cdcef3791f27840b5eedd690dc7176c0417f
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 56.0
Comment on attachment 8886820 [details] [diff] [review]
Bug1380898.patch

This is worth being uplifted since the totally collapsed box looks rather ugly.
Risk: Zero ;-)
Attachment #8886820 - Flags: approval-comm-esr52+
You need to log in before you can comment on or make changes to this bug.