If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

W2K Installer crashes while installing "Mozilla.XPCOM"

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Matthew Rubenstein, Assigned: dveditz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I run the mozilla installer, selecting only the default configs in the dialogs. It starts 
installing, then crashes while the installer dialog says it's installing "Mozilla.XPCOM". 
This started happening with the 0.9.8 installer, still happens with the 0.9.9 installer. I had 
previously installed versions thru 0.9.5 with no installer problems, but now every version's 
installer fails (talkback or not, stub or complete) as I describe. No other apps are running while 
the installer is running (I even quit the Explorer app once the installer app is launched). I 
always uninstall the previous version, and delete the mozilla.org folder, then reboot, before 
another install attempt. I have tried reinstalling Windows2000 (not wiping the disk, just a 
maintenance reinstall from the CD), but the problem is unchanged. I append the mozilla 
install_wizard.log. W2K traps the crashing installer exception and writes a log entry, which I 
could supply if told where to look in my filesystem. Please help, I can't stand using Opera 
anymore.

install_wizard.log :
     ** create folder: C:\Program Files\mozilla.org
     ** 
create folder: C:\Program Files\mozilla.org\Mozilla
     ** copy file: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\install_wizard.log to C:\Program 
Files\mozilla.org\Mozilla\install_wizard.log
     ** copy file: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\install_status.log to C:\Program 
Files\mozilla.org\Mozilla\install_status.log
     ** store registry value string: 
HKEY_CURRENT_USER\Software\mozilla.org\Mozilla\0.9.9 (en)\Setup [Setup State]
     ** 
create folder: C:\Program Files\mozilla.org\Mozilla\Plugins
     ** store registry value 
string: HKEY_LOCAL_MACHINE\Software\mozilla.org []
     ** store registry value string: 
HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla []
     ** store registry value string: 
HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla\0.9.9 (en) []
     ** store registry value 
string: HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla\0.9.9 (en)\Main [Program 
Folder Path]
     ** store registry value string: HKEY_CURRENT_USER\Software\mozilla.org []
     
** store registry value string: HKEY_CURRENT_USER\Software\mozilla.org\Mozilla []
     ** 
store registry value string: HKEY_CURRENT_USER\Software\mozilla.org\Mozilla\0.9.9 (en) 
[]
     ** store registry value string: 
HKEY_CURRENT_USER\Software\mozilla.org\Mozilla\0.9.9 (en)\Main [Program Folder Path]
     
** store registry value string: HKEY_LOCAL_MACHINE\Software\Mozilla []
     ** store registry 
value string: HKEY_LOCAL_MACHINE\Software\Mozilla\Seamonkey [CurrentVersion]
     ** store 
registry value string: HKEY_LOCAL_MACHINE\Software\Mozilla\Seamonkey\0.9.9 (en) []
     ** 
store registry value string: HKEY_LOCAL_MACHINE\Software\Mozilla\Seamonkey\0.9.9 
(en)\Main [Program Folder Path]
     ** create folder: C:\Program 
Files\mozilla.org\Mozilla\uninstall

Comment 1

16 years ago
Do you uninstall previous installations of Mozilla before trying a new install?
(Reporter)

Comment 2

16 years ago
        Yes. As I mentioned in my original bugzilla report:


I always uninstall the previous 
version, and delete the mozilla.org folder, then reboot, before another install attempt. 

Updated

16 years ago
Keywords: crash

Comment 3

16 years ago
I install Mozilla on a daily basis. Never seen this. I'm also on Win2k

Please try and run scandisk and perhaps try it on another machine.

Also please try to install using the full installer, the sea file one:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer-sea.exe
and see if you can reproduce.

You normally download this file:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer.exe
rite?
(Reporter)

Comment 4

16 years ago
Following your advice, I got identical crashing results when running mozilla-win32-installer-
sea.exe . I ran scandisk, but the installer still crashes the same way. If you tell me where to find 
it on my machine, I can send the logfile created (apparently by the Windows OS) when the installer 
crashes. I have only the one machine to use.

Comment 5

16 years ago
search your pc for the following files
install_wizard.log
install_status.log
and attach them to this bug report
(Reporter)

Comment 6

16 years ago
install_status.log , followed by install_wizard.log , appended:

install_status.log 
:
Start Log: 4/18/2002 - 5:10:44 PM
    System Info:
        OS Type: NT50
        Major Version: 5
        Minor 
Version: 0
        Build Number: 2195
        Extra String: 
        Total Physical Memory: 130520KB
        Total 
Available Physical Memory: 35824KB

    Product Info:
        Install mode: Normal
        Company name: 
mozilla.org
        Product name: Mozilla
        Uninstall Filename: MozillaUninstall.exe
        
UserAgent: 1.0.0+ (en)
        Alternate search path: 

    Components corrupted (startup):
        
none

    Destination Path:
        Main: C:\Program Files\mozilla.org\Mozilla
        SubPath: 

    
Setup Type: C&omplete

    Components selected:
        Mozilla XPCOM
        Navigator
        Mail & 
Newsgroups
        Personal Security Manager
        mozilla.org Uninstaller
        Chatzilla
        Debugger
        
US English profile defaults
        English (US) language pack
        US region pack
        Inspector
        
Quality Feedback Agent

    Components to download:
        Mozilla XPCOM found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        Navigator found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        Mail & Newsgroups found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        Personal Security Manager found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        mozilla.org Uninstaller found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        Chatzilla found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        Debugger found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        US English profile defaults found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        English (US) language pack found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        US region pack found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        Inspector found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        Quality Feedback Agent found: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\
        **
        ** All components have been found locally.  
No components will be downloaded.
        **

    Disk Space Info:
             Path: C:\
         Required: 40651KB
        
Available: 1187584KB

    Download protocol: FTP

    Download status: ok
        Mozilla XPCOM: 
NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Navigator: NetRetries:0, CRCRetries:0, 
NetTimeOuts:0
        Mail & Newsgroups: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Personal 
Security Manager: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        mozilla.org Uninstaller: 
NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Chatzilla: NetRetries:0, CRCRetries:0, 
NetTimeOuts:0
        Debugger: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        US English profile 
defaults: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        English (US) language pack: 
NetRetries:0, CRCRetries:0, NetTimeOuts:0
        US region pack: NetRetries:0, CRCRetries:0, 
NetTimeOuts:0
        Inspector: NetRetries:0, CRCRetries:0, NetTimeOuts:0
        Quality Feedback 
Agent: NetRetries:0, CRCRetries:0, NetTimeOuts:0

    Turbo Mode: false

    Uncompressing 
Xpcom Succeeded: 0

    XPInstall Start
        Mozilla XPCOM

install_wizard.log :
     ** create 
folder: C:\Program Files\mozilla.org
     ** create folder: C:\Program 
Files\mozilla.org\Mozilla
     ** copy file: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\install_wizard.log to C:\Program 
Files\mozilla.org\Mozilla\install_wizard.log
     ** copy file: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\install_status.log to C:\Program 
Files\mozilla.org\Mozilla\install_status.log
     ** create registry key: 
HKEY_CURRENT_USER\Software\mozilla.org\Mozilla\1.0.0+ (en)\Setup []
     ** store registry 
value string: HKEY_CURRENT_USER\Software\mozilla.org\Mozilla\1.0.0+ (en)\Setup [Setup 
State]
     ** create folder: C:\Program Files\mozilla.org\Mozilla\Plugins
     ** copy file: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\xpcom.ns\msvcirt.dll to 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\xpcom.ns\bin\msvcirt.dll
     ** copy file: 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\xpcom.ns\msvcrt.dll to 
C:\DOCUME~1\matt\LOCALS~1\Temp\ns_temp\xpcom.ns\bin\msvcrt.dll
     ** store registry 
value string: HKEY_LOCAL_MACHINE\Software\mozilla.org []
     ** store registry value string: 
HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla []
     ** create registry key: 
HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla\1.0.0+ (en) []
     ** store registry value 
string: HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla\1.0.0+ (en) []
     ** create 
registry key: HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla\1.0.0+ (en)\Main []
     ** 
store registry value string: HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla\1.0.0+ 
(en)\Main [Program Folder Path]
     ** store registry value string: 
HKEY_CURRENT_USER\Software\mozilla.org []
     ** store registry value string: 
HKEY_CURRENT_USER\Software\mozilla.org\Mozilla []
     ** store registry value string: 
HKEY_CURRENT_USER\Software\mozilla.org\Mozilla\1.0.0+ (en) []
     ** create registry key: 
HKEY_CURRENT_USER\Software\mozilla.org\Mozilla\1.0.0+ (en)\Main []
     ** store registry 
value string: HKEY_CURRENT_USER\Software\mozilla.org\Mozilla\1.0.0+ (en)\Main [Program 
Folder Path]
     ** store registry value string: HKEY_LOCAL_MACHINE\Software\Mozilla []
     ** 
store registry value string: HKEY_LOCAL_MACHINE\Software\Mozilla\Seamonkey 
[CurrentVersion]
     ** create registry key: 
HKEY_LOCAL_MACHINE\Software\Mozilla\Seamonkey\1.0.0+ (en) []
     ** store registry value 
string: HKEY_LOCAL_MACHINE\Software\Mozilla\Seamonkey\1.0.0+ (en) []
     ** create 
registry key: HKEY_LOCAL_MACHINE\Software\Mozilla\Seamonkey\1.0.0+ (en)\Main []
     ** 
store registry value string: HKEY_LOCAL_MACHINE\Software\Mozilla\Seamonkey\1.0.0+ 
(en)\Main [Program Folder Path]
     ** create folder: C:\Program 
Files\mozilla.org\Mozilla\uninstall

Comment 7

16 years ago
I'm soo unable to reproduce this. We haven't had a single bug report that looks
like this before. And you say that it's been happening since 0.9.8.

Please try to install onto another machine also running win2k.

Also try to exit *all* programs (antivirus, icq, etc) before installing Mozilla.
Use the task manager to kill "hidden" programs (SHIFT+CTRL+ESC)

I'm sure this bug is due to something wrong in your Win2k box
Severity: blocker → normal

Comment 8

16 years ago
Perhaps related: See bug 74522 comment 12

Can you try deleting all in the ns_temp dir and other dir's you unpack mozilla
to before a new install.
(Reporter)

Comment 9

16 years ago
     I delete Program Files\Mozilla.org\ and everything in it. I don't notice any temp dirs left 
behind after running the installer. I don't notice any temp dirs being created during the 
execution of the installer, and deleting any such temp dir seems like a risk. I merely execute the 
full installer, or the full installer sea, or the stub installer exe; I don't explicitly unpack 
any files separately from running the installer.

    I have only the single machine, running 
W2K, so I can't try to repro on another machine. I don't run any compilers or many plugins; 
basically a browser, Eudora (no plugins), Palm Desktop, and W2K telnet. I list the running 
processes below. I think a key to this problem could be in the state dump recorded when the 
installer crashes. I believe it's a default W2K debugger which traps the crash and writes the log. 
As I have suggested before, if you tell me where to look for the logfile, I will send 
it.

processes:
aim.exe CreateCD.exe csrss.exe Eudora.exe Explorer.exe HOTSYNC.exe 
loadkk.exe loadwin.exe lsass.exe minilog.exe mspmspsv.exe MSTaks.exe Opera.exe palm.exe 
RealPlay.exe regsvc.exe services.exe smss.exe spoolsv.exe svchost.exe svchost.exe System 
Syetem Idle Process taskmgr.exe vsmon.exe WCESCOMM.EXE Winampa.exe winlogon.exe 
zonealarm.exe

Comment 10

16 years ago
please try and shut down these processes before installing:
aim.exe
CreateCD.exe
Eudora.exe 
Opera.exe
palm.exe 
RealPlay.exe 
vsmon.exe
WCESCOMM.EXE
Winampa.exe
zonealarm.exe

make sure to delete everything in
C:\Documents and Settings\[user name]\Local Settings\Temp\

anyways I'm pretty sure this is not a mozilla bug but rather a weird bug at your
system....:(
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: crash
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

16 years ago
I killed those procs, and deleted all in the indicated Temp dir. Still the same failure. Where is 
the OS-debugger crash logfile, that is created at every crash, located? I expect it contains 
specific details of what causes the crash.

Comment 12

16 years ago
http://www.winguides.com/registry/category.php/60/
should provice some help about the dump file

perhaps combine it with filemon from
http://www.sysinternals.com/ntw2k/utilities.shtml
to find out where it crashes

Comment 13

15 years ago
Dr Watson log (assuming that is what you meant can be located in -c:\documents 
and settings\all users\documents\dr watson\)

also may be located other places - search for *.log
That however is not usually helpful but it is worth a try.

Comment 14

15 years ago
verified

reporter, is you disagree, please try with recent nightly build and reopen
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.