Closed Bug 1381010 Opened 2 years ago Closed 2 years ago

After resizing the window, open the onboarding overlay but the tours would not appear.

Categories

(Firefox :: New Tab Page, defect, P1)

56 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 56
Tracking Status
firefox56 --- fixed

People

(Reporter: Fischer, Assigned: Fischer)

References

Details

(Whiteboard: [photon-onboarding])

Attachments

(3 files)

STR:
1. Open about:home or about:newtab
2. Click the onboarding fox icon to open the onboarding overlay
3. Make sure the tours appear
4. Resize the window so that the onboarding overlay and the fox icon disappear
5. Resize the window again so that the fox icon appears again
6. Click the onboarding fox icon to open the onboarding overlay

Expected result:
The tours appear again.

Actual result:
The tours do not appear.
See the attached tours_disappear_after_resizing.gif for the real action.

Root Cause:
We are doing lazy load of the tours [1], which is good. However, at the step 2, the tours got loaded into the overlay once so `_tourItems` would be loaded with tours. Then at the step 6 we thought the tours should be loaded already because
 `_tourItems` was not empty. But in fact, we destroyed the overlay and created one new overlay without any tour loaded.

[1] https://dxr.mozilla.org/mozilla-central/rev/30ea2905130e85f9e1d8d56fa3097901eec6514b/browser/extensions/onboarding/content/onboarding.js#413
Assignee: nobody → fliu
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [photon-onboarding]
Version: 55 Branch → 56 Branch
Flags: qe-verify+
QA Contact: jwilliams
(In reply to Fischer [:Fischer] from comment #2)
> Created attachment 8886585 [details]
> Bug 1381010 - After resizing the window, open the onboarding overlay but the
> tours would not appear.
> 
> Review commit: https://reviewboard.mozilla.org/r/157406/diff/#index_header
> See other reviews: https://reviewboard.mozilla.org/r/157406/
Hi Mossop,
Please see attachment 8886584 [details]: fix_tours_disappear_after_resizing.gif for the fix in action, thanks
Comment on attachment 8886585 [details]
Bug 1381010 - After resizing the window, open the onboarding overlay but the tours would not appear.

https://reviewboard.mozilla.org/r/157406/#review162566
Attachment #8886585 - Flags: review?(dtownsend) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c94795e84153
After resizing the window, open the onboarding overlay but the tours would not appear. r=mossop
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c94795e84153
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
I can still reproduce this bug after pull the latest Nightly. Could you confirm that?
Flags: needinfo?(fliu)
Sorry, false alarm.
Flags: needinfo?(fliu)
I have verified that this bug is fixed with today's nightly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.