mail in subfolders lost completely

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
17 years ago
11 years ago

People

(Reporter: mlh, Assigned: naving)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020403
BuildID:    2002040314

I moved some folders to a subfolder of folder lists.
I had some filters which mozilla told me were updated.
When mail matching those filters came in mozilla said
those folders did not exist. I looked and they _were_ there
(in the mozilla side list).  To make the filters work
again, I moved them back out of the subfolder.  From then on
Mozilla behaved strangely, listing the wrong mail folder. 
(for instance, showing Inbox when I clicked some other folder)
I restarted mozilla, and now the folders that I had been moving
had gone.  I even checked from windows explorer.

Reproducible: Didn't try
Steps to Reproduce:
I will try and reproduce it with some less important
mail.

Comment 1

17 years ago
sounds more like a filters problem than mail database. -> navin
Assignee: bienvenu → naving
Component: Mail Database → Filters
(Reporter)

Comment 2

17 years ago
eh?  The filters weren't lost, the mail was.
I think the problem was just first discovered because
the filter complained, but they may well have no connection
whatsoever to this problem.

Comment 3

17 years ago
OK, mail backend (moving folders) - these are local folders, not imap folders, I
assume.
Component: Filters → Mail Back End
(Reporter)

Comment 4

17 years ago
They're not imap folders because I don't use imap. (Never have).
But.  They don't appear under the 'Local Folders' icon, they
come under my email address icon in the tree.  I'm not sure
what that means; they're still local folders right?  They sure
acted like them -- they work (up till now) and there is corresponding
file on the disk for each folder.

(Assignee)

Comment 5

17 years ago
I just tried the exact same steps. worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
QA Contact: gayatri → laurel

Comment 6

17 years ago
I just tried the scenario described on POP account using apr30 branch.  I had no
problems -- after moving the folders to subfolder level, I saw an alert(s) per
folder for the filter update(s), subsequent filters worked fine.  Then I moved
the folders back to the original level, got alert(s) that filter was updated and
filters still worked fine.  

Need more detail if you can reproduce the problem in a more current build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

17 years ago
Agreed.  I also tried to verify but couldn't.
I still think there is something there, FWIW.

I still don't know what the difference is between
the folders under the pop account and the folders
under the "local account". Anyone have a doc pointer?
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.