Cannot refresh the Discovery Pane in about:addons

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
a year ago
6 months ago

People

(Reporter: kumar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:

- Empty your cache
- Open Devtools and go to the Network tab
- Go to about:addons (in Release or Nightly)
- Notice that a request is made to the Discovery Pane (e.g. https://discovery.addons.mozilla.org/en-US/firefox/discovery/pane/56.0a1/Darwin/ignore)
- Hold shift and press the browser Refresh button to reload the page without cache

What happens:

As you can see in Devtools, the request to the Discovery Pane URL is cached

What should happen:

The request should not be cached

Other info:

- If you do a right click on the Discovery Pane iframe and seledct Reload then it is loaded without cache, as expected
- If you repeat these steps in a normal tab, the URL is not cached on reload, as expected
- This causes problems like bug 1380754 and it also has made QA difficult and confusion when trying to roll out new Discovery Pane features.
Duplicate of this bug: 1380754

Comment 2

a year ago
Based on bug 1380754 comment 10 we should probably just close this as won't fix?
Sure, I suppose so. The bug has caused confusion for QA when trying to test features as they land -- I don't think anyone knew what the bug was until now. I know about:addons is not fun code to work on though.
Kumar, can we make the right click process (the first step under other info in the original report) more widely understood among the AMO dev and QA teams?  Propagating reload all the way to AMO would mean teaching the js that backs about:addons to distinguish a "regular" load from a reload.  I don't know how practical that is...

If it helps, this is analogous to a regular HTML page that contains an <iframe> and a script that sets the src property on that iframe.  If you force-reload such a page, its script will be re-run, it will set the iframe src and that will do a regular (ie possibly from cache) load of the frame contents.  about:addons uses xul and <browser> instead of html and <iframe> but the basic process is the same...
(In reply to Andrew Swan [:aswan] from comment #4)
> Kumar, can we make the right click process (the first step under other info
> in the original report) more widely understood among the AMO dev and QA
> teams?  Propagating reload all the way to AMO would mean teaching the js
> that backs about:addons to distinguish a "regular" load from a reload.  I
> don't know how practical that is...
> 
> If it helps, this is analogous to a regular HTML page that contains an
> <iframe> and a script that sets the src property on that iframe.  If you
> force-reload such a page, its script will be re-run, it will set the iframe
> src and that will do a regular (ie possibly from cache) load of the frame
> contents.  about:addons uses xul and <browser> instead of html and <iframe>
> but the basic process is the same...

Since the behaviour is the same as a regular webpage I'm pretty happy to wontfix this - we don't need to special case the reload we just need to do a better job to communicate how to bust the cache, e.g. right click or appending a query string in about:config.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1381671
You need to log in before you can comment on or make changes to this bug.