If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

:first-letter doen't word together with a:hover at first position

VERIFIED DUPLICATE of bug 23604

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 23604
16 years ago
16 years ago

People

(Reporter: Dietmar Rabich, Assigned: dbaron)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

If using :first-letter for HTML-element p and a link with HTML-element a at
first position, the definition for :first-letter doesn't appear after the mouse
was over the link.

Reproducible: Always
Steps to Reproduce:
1. Make a document like this:

<html>
<head>
<style type="text/css">
p:first-letter {font-size: 2em;}
a:hover {color: red;}
</style>
</head>
<body>
<p><a href="#">Test</a></p>
</body>
</html>

2. Open the document in the browser-window.

3. Move the mouse pointer to the link and away.


Actual Results:  Before the mouse was moved to the link, the first letter has
double size, after normal size.

Expected Results:  The first letter should have the same size like before.

Comment 1

16 years ago
--> style
Assignee: sgehani → dbaron
Component: XP Apps → Style System
QA Contact: paw → ian

*** This bug has been marked as a duplicate of 23604 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
VERIFIED DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.