Closed Bug 1381283 Opened 2 years ago Closed 2 years ago

Intermittent crashtest command timed out: 7200 seconds elapsed, attempting to kill | stuck in 783041-2.html

Categories

(Core :: Graphics, defect)

42 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: aryx, Assigned: milan)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=114602723&repo=autoland

Tons of this for almost 2 hours:
11:18:17     INFO - --DOMWINDOW == 70 (0000002D0F0C6000) [pid = 4260] [serial = 52015] [outer = 0000000000000000] [url = file:///C:/slave/test/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html]
11:18:17     INFO - --DOMWINDOW == 69 (0000002D0F0CB800) [pid = 4260] [serial = 52016] [outer = 0000000000000000] [url = file:///C:/slave/test/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html]
11:18:17     INFO - --DOMWINDOW == 68 (0000002D0F0D6800) [pid = 4260] [serial = 52017] [outer = 0000000000000000] [url = file:///C:/slave/test/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html]
11:18:17     INFO - ++DOMWINDOW == 69 (0000002D06D1B800) [pid = 4260] [serial = 52064] [outer = 0000002D0A21F000]
11:18:17     INFO - ++DOMWINDOW == 70 (0000002D07924000) [pid = 4260] [serial = 52065] [outer = 0000002D0A21F000]
Assignee: nobody → milan
Flags: needinfo?(milan)
Comment on attachment 8887207 [details]
Bug 1381283: The original test is meant to simulate reloading until the crash.  Now that we're not crashing, we limit it to 10 reloads, to avoid any kind of a race condition and not terminating the test.

https://reviewboard.mozilla.org/r/157982/#review163466
Attachment #8887207 - Flags: review?(aosmond) → review+
Blocks: 1204281
fwiw, lots more failure reports in bug 1204281. The earliest I have found is https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=7745e88c749719bc64077ebb7e940ffe25d17b88, but it was so infrequent at that time it is hard to get an accurate regression range.
See Also: → 1381839
Pushed by msreckovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7a8c2db428e0
The original test is meant to simulate reloading until the crash.  Now that we're not crashing, we limit it to 10 reloads, to avoid any kind of a race condition and not terminating the test. r=aosmond
(In reply to Geoff Brown [:gbrown] from comment #5)
> fwiw, lots more failure reports in bug 1204281. The earliest I have found is
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> inbound&revision=7745e88c749719bc64077ebb7e940ffe25d17b88, but it was so
> infrequent at that time it is hard to get an accurate regression range.

Indeed, it looks like that is when this started. See https://bugzilla.mozilla.org/show_bug.cgi?id=1362903#c20 and https://bugzilla.mozilla.org/show_bug.cgi?id=1381839#c4.
Blocks: 1362903
(In reply to Pulsebot from comment #6)
> Pushed by msreckovic@mozilla.com:
> https://hg.mozilla.org/integration/autoland/rev/7a8c2db428e0
> The original test is meant to simulate reloading until the crash.  Now that
> we're not crashing, we limit it to 10 reloads, to avoid any kind of a race
> condition and not terminating the test. r=aosmond

:milan -- I don't see any calls to reload() in your patch. Shouldn't MaybeReload() sometimes call reload()?
Flags: needinfo?(milan)
https://hg.mozilla.org/mozilla-central/rev/7a8c2db428e0
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
(In reply to Geoff Brown [:gbrown] (pto July 21, July 24) from comment #8)
> ...
> 
> :milan -- I don't see any calls to reload() in your patch. Shouldn't
> MaybeReload() sometimes call reload()?

Right - changing the value of location.search reloads.  It appears to be what the standard allows ("Can be set, to navigate to the same URL with a changed query...") and seems to happen:
...
[task 2017-07-18T17:46:37.167591Z] 17:46:37     INFO - --DOMWINDOW == 45 (0x7fd9d1ab7800) [pid = 1013] [serial = 2500] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html]
[task 2017-07-18T17:46:37.168232Z] 17:46:37     INFO - --DOMWINDOW == 44 (0x7fd9995e9000) [pid = 1013] [serial = 2501] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html?10]
[task 2017-07-18T17:46:37.168406Z] 17:46:37     INFO - --DOMWINDOW == 43 (0x7fd9ce460800) [pid = 1013] [serial = 2502] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html?9]
...

although we still actually have a hang (see bug 1381933.)
Flags: needinfo?(milan)
Conversation continued in bug 1381933
Blocks: 1411358
No longer blocks: 1411358
You need to log in before you can comment on or make changes to this bug.