onblur event does not fire when form element is focused on using a label accesskey

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Ben Weaver, Assigned: joki (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When a form element such as an input of type text is focused on via ALT+K where
K is some key on the keyboard that has been associated with the input field by a
label tag, the onblur event will not fire when that input field looses focus.

To Reproduce:
   1. Go to the URL, http://outroad.org/mozillaLabelBlurBug.html
   2. Follow the instructions by hitting ALT+a on the keyboard
   3. Then click into B or press ALT+b on the keyboard

Actual Results:
   The following is printed:
      focus on A
      focus on B

Expected Results:
   The following should be printed:
      focus on A
      blur from A
      focus on B

Platforms verified on:
   build 2002041721 for Linux running on FreeBSD 4.5
   build 2002041103 on win2k

Comment 1

16 years ago
Confirming Win2k 1.0 RC1
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

16 years ago
WORKSFORME moz 2002092308 / win98
reporter, can you reproduce this with a newer build?
(Reporter)

Comment 3

16 years ago
Nope, it looks like the behavior is correct now.

Comment 4

16 years ago
r
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.