Old image from cache is sometimes displayed

VERIFIED INVALID

Status

()

Core
Networking: Cache
--
minor
VERIFIED INVALID
17 years ago
16 years ago

People

(Reporter: Warner Young, Assigned: gordon)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The Blue's News site changes its logo every week.  Occasionally, when visiting
the site after the logo has changed, I'll see the previous week's logo image
instead.  This is with the cache setting oon "When the page is out of date". 
Possibly this is due to the site setting something strange for its expiration,
but I never see this problem with NS 4.x or IE.

This is with build 2002041711, Win98, but I've been seeing this problem on and
off for months now.
(Reporter)

Comment 1

17 years ago
Created attachment 79779 [details]
Screenshot showing problem

Clicking the "Curious about the logo?" link will always show the correct image.

Comment 2

17 years ago
i will research this bug.

Comment 3

16 years ago
This problem does not seem to be limited to images. I have experienced this with
Wired's site on occasion where I get a day old main page even after having been
to the site that day. IE: I get the weekend main page on Monday afternoon
despite having gotten Monday morning's main page and even the mid morning update
during the day Monday. I have been looking for months for some correlated event
but I can not seem to find one. It is not very reproducible either. To make
things worse, my cache setting is set to "Once every session". This has also
happened with every version of Mozilla I have had including the release ver. 
(Assignee)

Comment 4

16 years ago
I took a look at that www.bluesnews.com, and it has no expiration set for it's
main page.  That will reduce how often we check for page changes.

In the case of "Check once per session", after we've checked for a page update,
we won't check again until you relaunch the browser.  You may want to change
your setting to "When the page is out of date", which is the current default.

I'm going to mark this bug as INVALID, but if you're still having problems
refreshing pages, feel free to reopen it and we'll continue the
discussion/investigation.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

16 years ago
Gordon, I haven't seen this problem in a while now, so it might be fixed. 
However, just wanted to note that my cache setting has never been changed from
default.  I just checked, and it's still set to "When page is out of date"

Comment 6

16 years ago
verified invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.