Make the speech bubbles 3px to the right of the fox icons

VERIFIED FIXED in Firefox 56

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: verdi, Assigned: rexboy)

Tracking

53 Branch
Firefox 56
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox56 verified)

Details

(Whiteboard: [photon-onboarding])

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

2 years ago
Posted image triangle.png (obsolete) —
The speech bubble in the onboarding notifications is missing a small triangle that points back at the fox.
Put it in triage. This is mainly because the rounded circle is easier to implement by just CSS and can be adapted to different size.
Whiteboard: [photon-onboarding] → [photon-onboarding][triage]
Whatever ended up landed in this bug please make sure it look alright in high contrast mode.
Flags: qe-verify+
Priority: -- → P2
QA Contact: jwilliams
Whiteboard: [photon-onboarding][triage] → [photon-onboarding]
Target Milestone: --- → Firefox 56
Reporter

Comment 3

2 years ago
Fred pointed out to me some of the difficulties in making this work. Instead let's not use the little triangle and instead, set the speech bubble 3px to the right of the fox icon.
Attachment #8886901 - Attachment is obsolete: true
Reporter

Updated

2 years ago
Summary: Notification speech bubble is missing a triangle → Make the speech bubbles 3px to the right of the fox icons
Thank Verdi, that will be easier to implement.

Rex, could you help integrate this spec into welcome message patch? (& dup this bug)
Flags: needinfo?(rexboy)
Solution included in another bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(rexboy)
Resolution: --- → DUPLICATE
Duplicate of bug: 1380963
remove whiteboard tag due to its DUPLICATE
Whiteboard: [photon-onboarding]
Looks like we introduced a padding by changing icon from DIV to BUTTON such that the bubble and the fox stuck together again. (See bug 1377439)

Let's have a quick patch to fix it.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [photon-onboarding]
Assignee: nobody → rexboy
Depends on: 1377439
Status: REOPENED → ASSIGNED
Priority: P2 → P1

Updated

2 years ago
Blocks: 1354046
Depends on: 1380963
Attachment #8889262 - Flags: review?(dtownsend)
Per survey in bug 1383660, this patch may no longer valid. I'll update status as patch ready there.
Attachment #8889262 - Flags: review?(dtownsend)
Seems the patch for 1383660 won't affect this bug. Mossop would you take a look for it? It's just a css one-liner.

Comment 11

2 years ago
mozreview-review
Comment on attachment 8889262 [details]
Bug 1381360 - Make the speech bubbles 3px to the right of the fox icons.

https://reviewboard.mozilla.org/r/160312/#review166310
Attachment #8889262 - Flags: review?(dtownsend) → review+

Comment 12

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/382ac74f97a2
Make the speech bubbles 3px to the right of the fox icons. r=mossop
Keywords: checkin-needed

Comment 13

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/382ac74f97a2
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
I have reproduced this bug with nightly 56.0a1 (2017-07-16) on Linux Mint (64 Bit).

The bug's fix is now verified on Latest Nightly 56.0a1

Build ID 	20170727100240
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170726]
I have successfully reproduced this bug with Nightly 56.0a1 (2017-07-16)  on windows 10(32bit)

this bug is verified fix with  latest nightly 56.0a1 (2017-07-27) (32-bit)

Build ID: 20170727100347
Mozilla/5.0 (Windows NT 10.0; rv:56.0) Gecko/20100101 Firefox/56.0

[bugday-20170726]

Updated

2 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.