Closed Bug 1381362 Opened 3 years ago Closed 3 years ago

Crash in mozilla::ConsoleReportCollector::`scalar deleting destructor''

Categories

(Core :: Networking: HTTP, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1363372
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- disabled
firefox56 --- affected

People

(Reporter: njn, Assigned: dragana)

References

Details

(Keywords: crash, Whiteboard: [necko-active])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-0cd57600-a666-4323-9c24-f4c2d0170714.
=============================================================

This started in Nightly 20170714030205 and has been happening since. It's happened 40 times across 35 installations.

The stack trace makes it look like there's some refcounting problem in the HttpBaseChannel destructor. Maybe there is some memory corruption, or premature free, or something like that?

Likely regression range is here:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=30ea2905130e85f9e1d8d56fa3097901eec6514b&tochange=67cd1ee26f2661fa5efe3d952485ab3c89af4271

Honza, you have a few changes in that range. Could any of them have caused this?
Flags: needinfo?(honzab.moz)
I'd more bet it was happening between bug 1377004 and bug 1377004.  Dragana?
Flags: needinfo?(honzab.moz) → needinfo?(dd.mozilla)
(In reply to Honza Bambas (:mayhemer) from comment #1)
> I'd more bet it was happening between bug 1377004 and bug 1377004.  Dragana?

yes, most probably yes :)
Assignee: nobody → dd.mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(dd.mozilla)
Whiteboard: [necko-active]
Duplicate of this bug: 1362831
Crash Signature: [@ mozilla::ConsoleReportCollector::`scalar deleting destructor''] → [@ mozilla::ConsoleReportCollector::`scalar deleting destructor''] [@ mozilla::ConsoleReportCollector::~ConsoleReportCollector]
Dragana, this is the #4 Windows topcrash in Nightly 20170721030204. Do you have a diagnosis, or do you know which patch caused the crash?
Flags: needinfo?(dd.mozilla)
(In reply to Nicholas Nethercote [:njn] from comment #4)
> Dragana, this is the #4 Windows topcrash in Nightly 20170721030204. Do you
> have a diagnosis, or do you know which patch caused the crash?

yes.
It is TFO. there is a pref to turn it off. I am trying to figure out why it is crashing therefore the TFO is on... I will turn it off before it goes to beta.
Flags: needinfo?(dd.mozilla)
This is the #3 and #9 Windows topcrash in Nightly 20170731100325 and 20170731175927. No new crashes after 7/31 so it looks like turning TFO off does stop the crash.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1363372
You need to log in before you can comment on or make changes to this bug.