Permanent simplejson.scanner.JSONDecodeError: Expecting value: line 1 column 1 (char 0) while trying upload to https://blobupload.elasticbeanstalk.com for WIndows buildbot jobs

RESOLVED FIXED

Status

RESOLVED FIXED
a year ago
7 months ago

People

(Reporter: aryx, Assigned: nthomas)

Tracking

Details

This started between 2017-07-15 23:21:40 PDT and 2017-07-16 01:06:01 PDT

First bad push: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=43676eab0672b3e86b33dcad9d672ac07e4c562f&selectedJob=114649649

Windows buildbot test jobs have this in the logs:

01:06:01     INFO - Copy/paste: C:\slave\test\build\venv\Scripts\python C:\slave\test\build\venv\Scripts\blobberc.py -u https://blobupload.elasticbeanstalk.com -a C:\slave\test\oauth.txt -b mozilla-inbound -d C:\slave\test\build\blobber_upload_dir --output-manifest C:\slave\test\build\uploaded_files.json
01:06:02     INFO -  Traceback (most recent call last):
01:06:02     INFO -    File "C:\slave\test\build\venv\Scripts\blobberc.py", line 253, in <module>
01:06:02     INFO -      main()
01:06:02     INFO -    File "C:\slave\test\build\venv\Scripts\blobberc.py", line 235, in main
01:06:02     INFO -      filetype_whitelist = get_server_whitelist(args['--url'])
01:06:02     INFO -    File "C:\slave\test\build\venv\Scripts\blobberc.py", line 69, in get_server_whitelist
01:06:02     INFO -      return set(response.json().get('whitelist', []))
01:06:02     INFO -    File "C:\slave\test\build\venv\lib\site-packages\requests\models.py", line 651, in json
01:06:02     INFO -      return json.loads(self.text or self.content, **kwargs)
01:06:02     INFO -    File "C:\slave\test\build\venv\lib\site-packages\simplejson\__init__.py", line 488, in loads
01:06:02     INFO -      return _default_decoder.decode(s)
01:06:02     INFO -    File "C:\slave\test\build\venv\lib\site-packages\simplejson\decoder.py", line 370, in decode
01:06:02     INFO -      obj, end = self.raw_decode(s)
01:06:02     INFO -    File "C:\slave\test\build\venv\lib\site-packages\simplejson\decoder.py", line 389, in raw_decode
01:06:02     INFO -      return self.scan_once(s, idx=_w(s, idx).end())
01:06:02     INFO -    File "C:\slave\test\build\venv\lib\site-packages\simplejson\scanner.py", line 119, in scan_once
01:06:02     INFO -      return _scan_once(string, idx)
01:06:02     INFO -    File "C:\slave\test\build\venv\lib\site-packages\simplejson\scanner.py", line 84, in _scan_once
01:06:02     INFO -      raise JSONDecodeError(errmsg, string, idx)
01:06:02     INFO -  simplejson.scanner.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
01:06:02    ERROR - Return code: 1
01:06:02     INFO - Setting buildbot property blobber_files to {}
01:06:02     INFO - Writing buildbot properties ['blobber_files'] to C:\slave\test\properties\blobber_files
01:06:02     INFO - Writing to file C:\slave\test\properties\blobber_files
01:06:02     INFO - Contents:
01:06:02     INFO -  blobber_files:{}
Duplicate of this bug: 1381787
(Assignee)

Comment 2

a year ago
I used the AWS console to execute the Action 'Rebuild Environment'. Now there is useful response to https://blobupload.elasticbeanstalk.com/blobs/whitelist.
Assignee: nobody → nthomas
(Assignee)

Comment 3

a year ago
Job which was failing blobber previously now sends data:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=580c3bee501632ffd24d1b0d2b37da6bdbe4fffa&selectedJob=115471900

Updated the alerts config to go to release+buildduty.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Comment hidden (Intermittent Failures Robot)

Updated

7 months ago
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.