Determine the impact of process-agnostic keyed histograms

RESOLVED FIXED

Status

()

P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: chutten, Assigned: chutten)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

a year ago
In bug 1380880 :billm discovered that histograms that shared the same key in different processes would have that key's data aggregated as though they weren't.

This is a problem. But how big of one?

What keyed histograms were affected by this?
What keys of those keyed histograms were affected?
How far back does this stretch? All the way back to bug 1218576 landing in 2016-09-20 (Firefox 52)?

To detect this:
1) Over all keyed histograms
2) Over all keys
3) Find keys that match in multiple processes
extra) Find histograms that are identical across the processes

From this we hope to learn how widespread the issue is and whether any high-value keyed histograms (if there are any) are affected. Then we'll send out an email to fx-data-dev letting everyone know.
(Assignee)

Comment 1

a year ago
https://github.com/mozilla/mozilla-reports/pull/70 up for review:

Highlights:

Yes, this appears to have been happening since all the way back in nightly/52. :(

No, this doesn't affect every keyed histogram. 

r?harter
(Assignee)

Comment 2

a year ago
r+ed by harter on github. Now at https://github.com/mozilla/mozilla-reports/blob/master/bug1381516.kp/knowledge.md

Now to post to fx-data-dev about it, then send emails to affected keyed histogram owners (as determined by the alert_emails fields)
(Assignee)

Comment 3

a year ago
All emails have been sent. So far, no replies. Yay!
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.