Closed Bug 138156 Opened 18 years ago Closed 18 years ago

ppembed crashes on 7100/66 if i try to load another page [Nubus]

Categories

(Core Graveyard :: Embedding: Mac, defect, critical)

PowerPC
Mac System 9.x
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 125411

People

(Reporter: timeless, Assigned: sdagley)

References

()

Details

(Keywords: crash)

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; PPC; rv:1.0rc1) Gecko/20020417
Embedding archive.
CarbonLib 1.5 (I had to upgrade, before i just got some error)
MacOS9.0.4

steps:
run PPEmbed
wait >3mins [it takes macie4.5 1/2min to launch]
mozilla.org loaded
in one case i visited about: (this worked)
then i tried to visit slashdot.org (crash)
in another, i tried to click on the tinderbox link from mozilla.org
Keywords: crash
> wait >3mins [it takes macie4.5 1/2min to launch]
Was this the first run? If so, it will take a while because the embedding dist
doesn't provide a pre-built component reg.

SleepQInstall being on the stack reminds me of another bug in which there's an
issue with being able to run on NuBus era Macs. I think beard may know something
about that.
well... it's happened a few times now. but i suppose i've never actually quit 
correctly (it's too easy to crash?)

but i thought that you shipped a pregenerated component.reg file so that 
shouldn't be the issue.  yes, NuBus sounds right.
see also bug 137470 (installer crash)
you were probably thinking of bug 138495.

I don't have a development environment, but I have bandwidth, so if someone 
made a test binary, I'd be more than willing to test it :-)
Summary: ppembed crashes on 7100/66 if i try to load another page → ppembed crashes on 7100/66 if i try to load another page [Nubus]
Looks related to bug 125411. But see comments in bug 137470.
Feel free to WONTFIX this one as we don't really consider the Carbon build, of
PPEmbed or Mozilla, qualified to run on anything but Mac OS X.  In fact we know
it'll have some problems but we don't prevent it from running as it's sometimes
useful for debugging.
> Feel free to WONTFIX this one as we don't really consider the Carbon build, of
PPEmbed or Mozilla, qualified to run on anything but Mac OS X.

I wouldn't WONTFIX it on those grounds. I think the Carbon build *should* run on
OS 9. I would, though, on the grounds that the machine on which this happens is
a 7100. That should be way, way below the minimum supported platform.

BTW, we have a minimum recommended platform but do we have a minimum supported
platform?
Reassigning since, if it only happens on such a machine which I have to access
to, I can't do much.
Assignee: ccarlen → timeless
I believe I know why the original patch did not work. Testing the CFM symbol for unresolved does not work; 
you have to test for presence of the SleepQInstall A-trap.

I took a raw MW template app and added these lines before its Run() method:

    if (&SleepQInstall != (void*)kUnresolvedCFragSymbolAddress) {
        DebugStr("\pSleepQInstall check 1 = looks resolved in CFM");
    }
	
    if (NGetTrapAddress(0xA28A, OSTrap) != NGetTrapAddress(_Unimplemented, ToolTrap)) {
        DebugStr("\pSleepQInstall check 2 = looks installed in trap table");
    }

On my system both test 1 and test 2 print. I DCCed the app to timeless on irc.mozilla.org #qa and on his 
Nubus system only the first test DebugStr appeared. That means the symbol showed up as resolved but 
the A-Trap was not present. That means changing the test my esteemed colleague Patrick checked in with the 
NGetTrapAddress test should fix the bug.

Greater stability risk of the proposed fix is extremely low: one change in one place, and it's relatively harmless 
if it gets falsely disabled. But this should work on any version of Mac OS 8-9 and is good practice.

Currently I am having build setup issues and cannot test it fully myself.
Reassigning to myself so I don't lose track of it
Assignee: timeless → sdagley
I created a patch based on tim's test, can someone spin a build for me with it?
fix checked in, thanks tim@maroney.org

*** This bug has been marked as a duplicate of 125411 ***
Status: NEW → RESOLVED
Closed: 18 years ago
No longer depends on: nubus
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.