Page source isn't available in breakpoint triggered in refresh with a file URI

RESOLVED WORKSFORME

Status

DevTools
Debugger
P1
normal
RESOLVED WORKSFORME
a year ago
a month ago

People

(Reporter: rhunt, Assigned: jlast)

Tracking

unspecified

Firefox Tracking Flags

(firefox57 wontfix, firefox58 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8887150 [details]
root-breakpoint.html

STR:

1. Open the attached file
2. Open Devtools > Debugger
3. Place a breakpoint on the alert()
4. Refresh the page

Observed Result:

The breakpoint is hit, but the source cannot be viewed or found in the sources list. I can't view what breakpoint has been hit, I can only hit continue until the page is loaded.

Expected Result:

The breakpoint is hit, and the source can be viewed allowing you to look at where the breakpoint is and perform debugging.
(Reporter)

Comment 1

a year ago
Ah, I just attempted this on the attachment hosted on bugzilla and wasn't able to reproduce. So I think this only happens on pages loaded over 'file://'
(In reply to Ryan Hunt [:rhunt] from comment #1)
> Ah, I just attempted this on the attachment hosted on bugzilla and wasn't
> able to reproduce. So I think this only happens on pages loaded over
> 'file://'

Same here. Interesting that it does work (even with a file URI) in the old debugger UI, so it's likely not a debugger server issue. Jason, is this a known issue with the new debugger?
Flags: needinfo?(jlaster)
Summary: Page source isn't available in breakpoint triggered in refresh → Page source isn't available in breakpoint triggered in refresh with a file URI

Updated

11 months ago
Component: Developer Tools → Developer Tools: Debugger
(Assignee)

Updated

10 months ago
Assignee: nobody → jlaster
status-firefox57: --- → fix-optional
Flags: needinfo?(jlaster)
Priority: -- → P1
(Assignee)

Comment 3

10 months ago
Thanks :rhunt for filing. I've moved it over to github, https://github.com/devtools-html/debugger.html/issues/4209

Updated

9 months ago
status-firefox57: fix-optional → wontfix
status-firefox58: --- → affected
Tested again with the new debugger on FF58 and the problem seems to be gone.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 5

5 months ago
Yep, it seemed to work well for me. We have done a bunch of work to guarantee showing files when we pause, so i'm not surprised it was a problem and that it was fixed.


STR:
1. download the root-breakpoint html file
2. open it at the file:// address for me it was file:///Users/jlaster/Desktop/root-breakpoint.html
3. add a breakpoint at alert
4. refresh

http://g.recordit.co/fWafGO9Ixe.gif

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.