horizontal scroll buttons non-functional on some pages after Bug 1364295

RESOLVED DUPLICATE of bug 1405397

Status

()

RESOLVED DUPLICATE of bug 1405397
a year ago
3 months ago

People

(Reporter: rontilby, Assigned: tnikkel)

Tracking

({regression})

58 Branch
mozilla56
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170717030207

Steps to reproduce:

Login to familysearch.org
Go to Family Tree > Find
Enter search criteria (entering "Mozilla" in last name field is sufficient.) and click "Find"

Here's an example URL:
https://familysearch.org/tree/find/name?search=1&self=|Mozilla|0|0&_=1500338812576

(I don't have the skillset to create a minimal testcase from the Family Tree results page, and I haven't found another example.

Here's the bisection info from the Mozregression program:
app_name: firefox
build_date: 2017-07-11 20:25:57.759000
build_file: C:\Users\Ron\.mozilla\mozregression\persist\f691dec773ee--mozilla-inbound--firefox-56.0a1.en-US.win64.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/PA91rvh5RgGF8fZeiKqCnQ/runs/0/artifacts/public%2Fbuild%2Ffirefox-56.0a1.en-US.win64.zip
changeset: f691dec773ee7019242e5d2c2402a9a8302b7bdc
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f691dec773ee7019242e5d2c2402a9a8302b7bdc&tochange=1fcc2c629f1be51d4746a9a881c5ff83b0315890
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: PA91rvh5RgGF8fZeiKqCnQ

Here's the Log view tail from the Mozregression program:


Actual results:

On the search results page, click the right horizontal scroll arrow.
nothing happens!

Dragging the horizontal scroll bar results in text selection and vertical scrolling.
2017-07-17T15:18:36: INFO : Narrowed inbound regression window from [f691dec7, bc4c5281] (3 revisions) to [3b5eec74, bc4c5281] (2 revisions) (~1 steps left)
2017-07-17T15:18:36: DEBUG : Starting merge handling...
2017-07-17T15:18:36: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=bc4c5281f2c23c7d643c6c5580789047c5f0c0ec&full=1
2017-07-17T15:18:37: DEBUG : Found commit message:
Bug 1379887. Don't clobber the value of mWillBuildScrollableLayer when we are building a display list for event handling. r=mstange

ScrollFrameHelper::DecideScrollableLayer doesn't get the actual value of usingDisplayPort/wasUsingDisplayPort if we are not painting to the window. It then sets mWillBuildScrollableLayer to usingDisplayPort. mWillBuildScrollableLayer is the value that determines if we are active and hence an ASR, we don't want to change that between paint display lists for an event handling display list.

We then want to condition uses of mWillBuildScrollableLayer and the return value of DecideScrollableLayer on if we want painting to the window so we get the same behaviour as before when not painting to the window.

2017-07-17T15:18:37: INFO : The bisection is done.
2017-07-17T15:18:37: INFO : Stopped



Expected results:

The page should scroll horizontally.
Blocks: 1379887
Has Regression Range: --- → yes
Component: Untriaged → Layout: Web Painting
Flags: needinfo?(tnikkel)
Keywords: regression
Product: Firefox → Core
(Assignee)

Updated

a year ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

a year ago
Should be fixed by backout of bug 1379887.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(tnikkel)
Resolution: --- → FIXED
Assignee: nobody → tnikkel
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox56: --- → fixed
status-firefox-esr52: --- → unaffected
Target Milestone: --- → mozilla56
(Reporter)

Comment 2

a year ago
This bug has returned in recent nightly builds (at least on Windows 10, 64 bit).

STR: Use the original steps in comment 0 or

start recent nightly build (for example 58.0a1 (2017-10-05) (64-bit)
Make the window width narrow.
go to https://www.google.com
In the search bar enter: Utah Museum of Fine Arts
When the search results page is loaded, press the right-scroll arrow at the bottom of the window to scroll the page to the right.

Result: Nothing happens

Expected result: The page should scroll to the right.

If I drag the horizontal scroll bar, I get BOTH vertical and horizontal scrolling with text selection.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 3

a year ago
Another STR:
Start the browser
Make the window narrow
Load https://getsatisfaction.com/familysearch
Try to scroll horizontally by pressing the > scroll button at the bottom of the window.

Mozregression results (I'm not sure what is useful to paste from mozregression-gui)
app_name: firefox
build_date: 2017-10-02 23:35:20.687000
build_file: C:\Users\Ron\.mozilla\mozregression\persist\7dc34fa77f39--mozilla-inbound--target.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/UVDgCsRfRgOpdSc-2tHsgw/runs/0/artifacts/public%2Fbuild%2Ftarget.zip
changeset: 7dc34fa77f398c2156194e739c79ed48f94c6cf0
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=53f386c373de031566dc94468b3c21c390079fb2&tochange=7dc34fa77f398c2156194e739c79ed48f94c6cf0
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: UVDgCsRfRgOpdSc-2tHsgw

2017-10-06T17:33:31: INFO : Narrowed inbound regression window from [53f386c3, 4c8b85e8] (3 builds) to [ce3e3c2f, 4c8b85e8] (2 builds) (~1 steps left)
2017-10-06T17:33:31: DEBUG : Starting merge handling...
2017-10-06T17:33:31: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=4c8b85e80aebb27cf3a5334c2c183e49636b9ece&full=1
2017-10-06T17:33:31: DEBUG : Found commit message:
Bug 1364295. Simplify some code now that we don't create displayports during display list building. r=mstange

2017-10-06T17:33:31: INFO : The bisection is done.
2017-10-06T17:33:31: INFO : Stopped
(Reporter)

Updated

a year ago
Blocks: 1364295
Summary: horizontal scroll buttons non-functional on some pages after bug 1379887 → horizontal scroll buttons non-functional on some pages after Bug 1364295
Version: 56 Branch → 58 Branch
(Assignee)

Comment 4

a year ago
Patches in bug 1405397 should fix this.
(Assignee)

Comment 5

a year ago
Should be fixed now. Please reopen if not.
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1405397
You need to log in before you can comment on or make changes to this bug.